Компьютерные сети и Интернет Учебно-методическое пособие




НазваниеКомпьютерные сети и Интернет Учебно-методическое пособие
страница6/6
Дата05.10.2012
Размер1.28 Mb.
ТипУчебно-методическое пособие
1   2   3   4   5   6

3.7. Задание





  1. Составьте адрес в Интернет Web-сайта всемирно известной фирмы (Intel, IBM, Sony и т.д.) и откройте его в Internet Explorer.

  2. Используя тот же прием, перейдите на Web-сайт Санкт-Петербургского государственного университета и далее, тем же способом, перейдите на Web-сайт факультета прикладной математики Санкт-Петербургского государственного университета.

  3. Загрузите в окно Internet Explorer по очереди поисковые системы согласно таблице адресов (см. табл. 3.1).

  4. В каждой поисковой системе выполните несколько запросов, затрагивающих проблемы образования (среднего образования для русскоязычных Web-сайтов) и откройте найденные документы.

  5. Используя операторы языка запросов (см. табл. 3.2), с помощью системы АПОРТ получите информацию об интересующем вас школьном предмете (математика, физика, информатика и т.д.).

  6. Опробуйте поиск по тематическим каталогам (см. п. 3.2).

  7. Используя систему files (www.files.ru) найдите в Интернет инсталляторы клиентов таких служб, как www, ftp, IRC, ICQ.

  8. Используя поисковые системы, спланируйте (разработайте) оптимальный маршрут переезда из Санкт-Петербурга в город из списка, указанного ниже. Критерий оптимальности – минимизация временных и материальных ресурсов. Дата отбытия из Санкт-Петербурга – начиная с завтрашнего дня. Варианты городов назначения: Тегеран, Турин, Сидней, Сеул, Торонто, Венеция, Брюссель, Харбин, Тулуза, Детройт, Бирмингем, Белфаст, Сан-Франциско.

  9. Проведите обзор ресурсов сети Интернет, указанных в п. 3.6.



4. РАБОТА С ПРОГРАММОЙ WINDOWS NETMEETING 3.01


  1. Общие сведения


Программа NetMeeting позволяет людям общаться друг с другом через компьютерную сеть, а именно:

  • выполнять вызовы, используя локальную сеть или Интернет;

  • вести разговор через Интернет или локальную сеть;

  • видеть вашего собеседника;

  • работать в приложении вместе с другими пользователями;

  • рисовать на общей доске во время интерактивной встречи;

  • просматривать список пользователей, подключенных к серверу;

  • отправлять письменные сообщения собеседнику;

  • отправлять файлы всем участникам встречи.


После вызова программы на экране появится окно, см. рис. 4.1. Если программа NetMeeting запускается первый раз после установки на компьютер, то она предложит заполнить специальную форму, где вы указываете свою информацию (имя, Е-mail и т.д.). Впоследствии эту информацию можно изменить в диалоговом окне Options на вкладке General, вызываемом командой Tools/Options.

Следующим шагом необходимо обеспечить соединение с другими пользователями. Основные способы поиска пользователей: по имени компьютера, IP-адресу или на сервере каталогов.

Для выполнения вызова наберите имя компьютера пользователя, которого вы хотите вызвать и нажмите кнопку Call (Call/New Call). Если вы нажмете кнопку Call при незаполненном поле адреса, то появится диалоговое окно Place A Call, где будет необходимо указать имя компьютера, с которым вы хотите связаться.


Рис. 4.1. Окно программы NetMeeting
Когда кто-то вызывает вас, возле панели задач открывается диалоговое окно. Чтобы принять вызов, нажмите кнопку Accept . Чтобы отклонить поступивший вызов, нажмите кнопку Ignore. Чтобы стать недоступным для всех вызовов выберите в меню Call команду Do Not Disturb. Можно настроить автоматический прием всех вызовов (Call/Automatically Accept Calls). После успешного соединения в окне программы NetMeetin формируется список участников. Ниже списка расположены кнопки основных приложений:

Chat; Whiteboard; Transfer Files; Share program.


4.2. Приложение Chat

Приложение Chat позволяет вести разговор со всеми участниками в текстовом режиме. Для запуска приложения нажмите на панели инструментов кнопку Chat. Откроется окно Chat, где вы можете следить за разговором, набирать и передавать сообщения. Можно «шептать» сообщения, то есть во время разговора со многими собеседниками что-то отдельно передать одному из них, указав конкретного получателя.


4.3. Приложение Whiteboard


Приложение Whiteboard позволяет формировать графические объекты на общей доске доступной всем участникам конференции. При запуске приложения открывается окно, похожее на окно программы Paint, c этого момента все участники текущей встречи смогут видеть доску и пользоваться ей. Графические объекты могут располагаться на нескольких страницах. Указатель текущей страницы и кнопки управления ими находятся в нижнем правом углу окна.

Программа Whiteboard является объектно-ориентированной (в отличие от точечно-ориентированных), что позволяет управлять содержимым доски с помощью мыши.

Использование удаленного указателя или маркера (View/Remote Pointer) позволяет привлечь внимание партнеров к определенным фрагментам общих страниц.

Можно запретить другим пользователям изменять содержимое доски, выбрав команду View/Lock Contens.

4.4. Приложение Transfer Files


Приложение Transfer Files выполняет передачу файлов между компьютерами участников встречи. Данная возможность позволяет в фоновом режиме отправить файл одному или всем пользователям, находящимся на связи и принимать от них файлы.

Для запуска приложения необходимо нажать кнопку Transfer Files, после чего откроется окно (рис. 4.2), где вы можете управлять передачей и приемом файлов.

Для передачи файла в окне приложения выберите команду Add File меню File и выберете файлы, которые вы хотите передать. Другой способ выбора файла заключается в перетаскивании файла в данное окно. Файлы могут быть переданы всем участникам встречи (Everyonet) или конкретному собеседнику. Для передачи файла необходимо нажать кнопку Send All.

Е
сли файл передают вам, на экране появляется окно с сообщением о передаче файла с указанием имени файла, его объема и имени отправителя. Если вы не хотите сохранять этот файл нажмите кнопку Delete, иначе Close. Файлы сохраняются в папке NetMeeting\Received Files. Для открытия этой папки можно воспользоваться кнопкой View reseived files.

4
Рис.4.2. Окно приложения передачи файлов

.5. Приложение Share program


Приложение Share program дает возможность совместно использовать программу, работающую на одном компьютере.

Если вы хотите, чтобы несколько участников встречи работали в вашем приложении, необходимо прежде всего открыть это приложение. Запустить Share program и в открывшемся окне выбрать приложение, которое вы хотите сделать доступным для других.

Человек, предоставивший приложение в общее пользование, может установить режим сотрудничества с другими участниками конференции; это позволит им поочередно участвовать в редактировании или управлении работой приложения. При этом достаточно, чтобы это приложение было установлено только у того, кто передал его в общее пользование. Для этого необходимо выбрать степень доступности приложения: Allow Control или Prevent Control.

В режиме Prevent Control все участники встречи смогут видеть приложение, но не смогут его использовать. Такой режим полезен для демонстрационных целей.

Если вы выберете Allow Control, то приложение может использоваться для совместной работы всеми участниками встречи, выбравшими режим сотрудничества, которые также смогут последовательно работать вместе с вами. Если вы передаете в общее пользование окно проводника Windows, Desktop, или окно папки на вашем компьютере, то все открываемые вами окна будут окнами общего пользования. Кроме того, если предоставить такое окно в общее пользование, то любое приложение, запускаемое вами во время вашего участия во встрече, также автоматически перейдет в общее пользование.

Чтобы прекратить совместную работу в своем приложении, нажмите клавишу ESC. После этого все участники встречи смогут только наблюдать за работой.


4.6. Задание

  1. Запустите NetMeeting.

  2. Заполните специальную форму, где укажите информацию о себе. Изменить эту информацию можно в диалоговом окне Options на вкладке General, вызываемом командой Tools/Options.

  3. Выполните соединение с другим пользователем, находящимся за соседним компьютером.

  4. С использованием приложения Chat выполните обмен несколькими сообщениями друг с другом.

  5. С использованием приложения Whiteboard выполните совместное рисование на общей доске. Опробуйте различные возможности приложения Whiteboard: использование удаленного указателя, запрещение другим пользователям изменять содержимое доски.

  6. Запустите текстовый редактор Microsoft Word и с помощью приложения Share program предоставьте его в совместное использование. Проверьте различные режимы работы. Сохраните полученный файл. Затем поменяйтесь ролями и освойте работу с приложением компьютера соседа.

  7. Освойте процедуру пересылки файлов с помощью приложения Transfer Files.

  8. Выполните соединение с другими пользователями, находящимися в вашем классе. Создайте в редакторе Notepad текстовый файл с информацией о номере вашей машины и разошлите его. Посмотрите файлы, присланные вам.

  9. Завершите работу NetMeeting. Для этого сначала нажмите кнопку End Call, а затем закройте окно программы. Несоблюдение этой последовательности может привести к зависанию приложения.
  1. КЛИЕНТ ICQ



ICQ (I Seek You, «аська» жарг.) – программа, первая версия которой создана компанией Mirabilis в 1996 году, для общения в Интернет. ICQ служба позволяет общаться в реальном времени посредством клавиатуры (англ. Chat – разговор). Достоинством этой службы является то, что ICQ-клиент распространяется бесплатно и имеет русифицированные версии.

Каждый пользователь ICQ имеет свой собственный Personal Communication Center (Центр Связи) на сервере ICQ по адресу www.icq.com/uin_пользователя. Здесь расположена основная информация о вас (та, которую вы сами сделали доступной для других пользователей), пейджер, через который с вами могут связаться люди, не имеющие ICQ. Отсюда же они могут узнать ваш статус в сети, инициализировать сеанс чата на вашу программу ICQ или послать вам ICQ сообщение. Кроме того, пользователи могут послать вам оттуда письмо прямо на ICQ (лимит – до 450 символов). Здесь же расположен чат клиент IrCQ – аналог IRC в ICQ.


  1. Установка и регистрация


Программа бесплатно распространяется с сервера http://www.mirabilis.com. Для установки программы необходимо войти на этот сервер, скачать программу себе на диск, запустить полученный файл и следовать появляющимся на экране указаниям. (Программу установки icq2000a.exe можно скачать и с других серверов, например, со страницы fio.ifmo.ru/ internet).





Рис. 5.1. Окно

программы ICQ
5.2. Основные принципы работы


После загрузки программы ICQ на экране появляется контактный лист с ICQ-номером, написанным в верхнем левом углу (см. рис.4.1).

Как только вы выходите в Интернет, ICQ начинает активизироваться. Если связь хорошая и программа смогла соединиться с сервером, через который проходят все ICQ-сообщения, появляются маленькая иконка в правом нижнем углу монитора в виде зеленого цветка и соответствующее сообщение. Если соединение не установлено, иконка будет красного цвета. При пропадании связи программа начнёт новую попытку соединения, при этом иконка так же изменит вид.

На контактном листе сосредоточены все кнопки управления программой.

Кнопка To Simple Mode / To Advanced Mode позволяет выбрать режим работы. В простом (Simple) режиме возможен только обмен сообщениями. Другие возможности становятся доступными в расширенном (Advanced) режиме.

В качестве первого шага необходимо найти друзей и знакомых, с которыми вы бы хотели вести общение.


5.3. Поиск собеседников


Для составления списка друзей и знакомых в контактном листе нажмите Add Users, после чего откроется окно программы поиска пользователей IСQ.

Поиск можно вести тремя способами: 1) по номеру ICQ; 2) по e-mail; 3) по псевдониму (nickname), но этот способ годится, если nick уникален, иначе вам выдадут список всех пользователей со всего мира.

П



Рис. 5.2. Выбор собеседника
ри обнаружении требуемого человека необходимо воспользоваться контекстным меню (рис. 5.2) с командами:

  • Add to Contact List – внести избранного человека в контактный лист;

  • Add To Address Book – внести в адресную книгу;

  • Info – получить информацию о пользователе;

  • Message – послать сообщение, не внося в контактный список;

  • View User's IСQ Page – посмотреть IСQ-страницу пользователя.

Чтобы начать поиск нового собеседника, нужно нажать New Search. Поиск можно также вести с помощью мастера Wizard Mode. Если вы не нашли знакомого, значит он не зарегистрировался в ICQ или не захотел, чтобы его нашли, выбрав опцию анонимности.


5.4. Передача сообщений


После того, как вы нашли собеседника, пошлите запрос на добавление вас в его контактный список. Если вам дали разрешение на добавление в контактный лист вашего знакомого, вы получите сообщение You Were Added.

Сообщение Authorize User Request – запрос на разрешение добавить вас к своему контактному листу. Другие системные сообщения:

  • Authorize User Reply Message – ответ на запрос о добавлении кого-то в ваш контактный лист;

  • Notify Message – сообщает о том, что определённый пользователь зарегистрировался в ICQ;

  • Automatically Add to List Request – запрос на автоматическое добавление вас к своему контактному листу;

  • Server Message – сообщения с сервера ICQ.

Если вы получили системное сообщение, то в System Menu и возле псевдонима отправителя мигают иконки. Дважды щелкните по иконке и вы пополните контактный список новым пользователем. По контактному списку вы видите, кто в находится в режиме online. Пользователи вашего контактного листа могут находиться в различных состояниях:

  • Online – пользователи, чьё ICQ активировано;

  • Offline – пользователи, чьё ICQ не активировано или они не в сети;

  • Waiting Authorization – пользователи, ожидающие разрешения на добавление в контактный лист;

  • Future Users – знакомые, которые не зарегистрированы в ICQ, но, как только зарегистрируются, вы сразу об этом узнаете;

  • Not In List –пользователи, появляющиеся на панели контактного листа после пересылки вам сообщения, но которые исчезнут из списка после отключения вами ICQ.

Если вы хотите внести их в список, то нажмите Not In List / Add to Contact List.

Для отправления сообщения надо щелкнуть по псевдониму пользователя в контактном листе и в открывшемся меню выбрать Message. Не имеет значения, находится в сети получатель вашего сообщения, или нет. Если он в сети, то получит сообщение сразу, а если нет, то получит сразу же, как только войдёт в сеть и ICQ активизируется. После того, как вы нажмёте Message, откроется окно сообщения, в котором можно написать послание, содержащее не более 450 символов.

Вы также можете принимать сообщения. При посылке вам сообщения возле псевдонима отправителя и вместо цветочка на контрольной панели начинает мигать иконка. Щелкнув по иконке два раза, вы откроете окно сообщения. Можно ответить на сообщение, можно просто закрыть окно, не отвечая.


5.5. ICQ – chat


ICQ не ограничивается только передачей сообщений. Чтобы поболтать с кем-то, можно открыть ICQ – chat. Но, в отличие от сообщений (Messege), пригласить на chat можно только пользователя, находящегося в состоянии online.

Для открытия chat щелкните на псевдониме пользователя, с которым вы хотите поболтать, и в открывшемся меню выберите chat : в открывшемся окне запроса на chat можно написать пару слов (приглашение) и нажать кнопку chat — запрос послан.

Если ваш запрос принят, то вскоре вы окажетесь в chat и сможете пообщаться.

Если вас приглашают на chat, то возле псевдонима приглашающего начинает мигать иконка.

Щелкнув по кнопке Accept в окне приглашения, вы откроете chat. Если вы не хотите в данный момент общаться, нажмите кнопку Do not accept. Если вы хотите объяснить отказ, выберите Chat Reason.

Для того чтобы в chat было несколько человек, нужно перетащить псевдоним нового собеседника в нижнее окно chat. В этом случае не надо щелкать по псевдониму ещё одного собеседника и приглашать на chat. Как только его псевдоним окажется в нижнем окне, это послужит приглашением.


5.6. Пересылка


ICQ даёт возможность отправлять файлы, URL (ссылки на страницы), e-mail (электронная почта), контакты с пользователями вашего контактного листа другим «жителям» ICQ. Отличительной особенностью ICQ является то, что все эти пересылки происходят в режиме реального времени.

Передача и получение файлов. Прежде чем получить файл, вы должны подтвердить получение. При посылке вам файла возле псевдонима пользователя-отправителя и вместо цветочка на контрольной панели замигает иконка. Щелкнете на псевдониме пользователя и в открывшемся меню выберите Receive . Если вы не отказываетесь принять файл, то есть два варианта его записи:

  • Save – все записываемые файлы сохранятся в каталоге Program Files\ICQ\Reseived Files;

  • Save To – можем выбрать любой каталог для записи получаемого файла.

Для передачи файла необходимо щелкнуть на псевдониме пользователя, которому вы посылаете файл и в открывшемся меню выбрать File . После этого вы должны выбрать передаваемый файл, передачу которого можно снабдить кратким комментарием. Назначение кнопок:

  • Select File(s) – выбор файла;

  • Send – отправить.

Замечание. Пользователь-получатель должен обязательно находиться в online, т.е. его ICQ должна быть активизирована.

После согласия пользователя на получение, файл начнёт перекачиваться.

Пересылка и получение URL (ссылки на Web-сайты). URL Message (Сообщение со ссылкой на Web-страницу) состоит из адреса Web-сайта и комментария. Чтобы отправить URL, необходимо щёлкнуть на псевдониме получателя и выбрать в открывшемся меню команду Web Page Address (URL). После этого в диалоговом окне можно заполнить поля Select/ Enter URL (Выбор/Ввод URL), Enter URL Description (Ввод описания URL) и отправить сообщение (кнопка Send).

При получении URL возле псевдонима отправителя и вместо цветочка на контрольной панели замигает иконка. Щелкнув по ней вы откроете окно, в котором отображаются возможные действия в ответ на получение URL:

  • Go To URL – перейти по указанному адресу;

  • Add To Bookmark – занести в записную книжку.

Пересылка и получение контактов. С помощью данной функции вы можете познакомить всех пользователей вашего контактного листа друг с другом. Для этого щелкните по имени получателя контакта и выберите Contacts. В открывшемся окне находится список всех ваших ICQ-контактёров. Выберите нужных кандидатов для нового знакомства, нажмите Select, и кандидаты перемещаются в Contacts To Send. Если вы передумали отправлять какой-нибудь контакт, выделите в Contacts To Send соответствующий псевдоним и нажмите Remove. Для пересылки контактов нажмите Send, после чего указанные пользователи отправятся в контактный список вашего знакомого.

При получении контактов, возле имени отправителя и вместо цветочка на контрольной панели, замигает иконка. Вы вовсе не обязаны принимать в свой список всех подряд, поэтому вы можете сначала посмотреть информацию собеседников из списка Get User Info, пообщаться с ними, отправив сообщения Send Message, но не добавлять их в свой контактный список или вовсе закрыть окно контактов, нажав Close. Если присланный собеседник не вызывает у вас сомнений или вы без проверок доверяете приславшему контакт, нажмите Add To Contact List, после чего собеседник отправится в ваш список.

5.7. Задание





  1. Запишите (скачайте) на диск своего компьютера программу установки ICQ – клиента. Программу icq2000a.exe можно скачать со страницы fio.ifmo.ru/ internet.

  2. Запустите эту программу и следуйте всем указаниям по установке ICQ – клиента на вашем компьютере.

  3. Установите связь и обменяйтесь сообщениями с другим пользователем ICQ.

  4. Выполните передачу и прием файлов и URL.

  5. Организуйте чат.




  1. ДОСТУП К FTP-СЕРВЕРАМ С ИСПОЛЬЗОВАНИЕМ

ПРОГРАММЫ FAR MANAGER 1.63


6.1. Общие сведения


Работа с программной оболочкой FAR может вызвать ностальгические нотки по работе с уходящими в небытие программами типа Norton Commander. Именно для поколения, привыкшего работать в операционной системе DOS и был создан FAR. Так называемый интерфейс FAR мало чем отличается от программы Norton Commander. Те же самые меню и цвет экрана, похожее по содержанию Управляющее меню, но все же – это приложение Windows.

Перед началом работы в программе FAR рекомендуем перейти к русскоязычному описанию меню. Для этого необходимо проделать следующие действия:

  • нажмите клавишу F9 (либо щелкните по клавише ConfMn);

  • выберите вкладку Options в появившемся в верхней части экрана меню и нажмите клавишу Enter;

  • выберите вкладку Languages и нажмите клавишу Enter;

  • в открывшемся окне MainLanguage выберите Russion (Русский) и нажмите клавишу Enter;

  • в окне Язык помощи выберите Russion (Русский).

Несколько слов о работе в текстовом редакторе программы FAR. Для создания текстового документа нажмите клавиши Shift F4 и в появившемся окне Редактор, введите имя файла. После нажатия клавиши Enter вы переходите в текстовый редактор программы FAR. В верхней части окна слева направо отображены: имя файла, текущая кодировка, номер текущей строки и общее количество строк в документе, а также номер текущего символа в строке. В нижней части экрана находится меню данного текстового редактора. При работе в текстовом редакторе вам могут понадобиться следующие наиболее употребляемые комбинации клавиш (см. табл. 6.1).






Таблица 6.1. Комбинации клавиш

Ctrl A

Выделение всего текста

Ctrl C

Копирование выделенного фрагмента текста в буфер обмена

Ctrl X

Перенос выделенного фрагмента текста в буфер обмена

Ctrl V

Вставка из буфера обмена

Ctrl Y

Удаление текущей строки

Shift 

Выделение фрагмента текста

Shift 

Выделение фрагмента текста


Текстовый редактор программы FAR позволяет работать с различными типами кодировок. В верхней части окна отображена текущая кодировка. Если она вас не удовлетворяет, то переход к другому типу кодировки может быть осуществлен либо нажатием клавиши F8, либо нажатием клавиш Shift F8.

Подключение (установка) кодировок. Если FAR не поддерживает какую-либо кодировку, например, кодировку Кириллица KOI8-R, то для ее установки проделайте следующие действия:

  • перейдите в корневой каталог программы FAR;

  • перейдите последовательно в каталог Addons, Tables, Russian и загрузите файл koi-8.reg;

  • в появившемся окне выберите вкладку Yes, далее щелкните по кнопке ОК.

Аналогичным образом можно подключить другие виды кодировок.

Изменение кодировок в текстовом редакторе FAR. Если вы хотите изменить текущую кодировку текста (например, ваш текст создан в DOS-кодировке, а вы хотите чтобы он читался в кодировке KOI8-R), необходимо:

  • выбором кодировки привести отображаемый текст к читабельному виду;

  • вырезать фрагмент документа, подлежащего перекодировке, в буфер обмена;

  • сменить кодировку на желаемую;

  • вставить фрагмент документа из буфера обмена.


6.2. Общие сведения о службе FTP


Интернет является самым большим в мире храни­лищем файлов. Множество подключенных к Ин­тернет узлов содержат гигабайты полезной ин­формации, доступной для пользо­вателей Интернет.

Для хранения файлов в Интернет используются специальные FTP-серверы. Некоторые из них открыты для свободного доступа, их часто называют анонимными серверами. Другие доступны только для ограниченного круга зарегистрированных пользователей и тре­буют при подключении ввода идентификатора и пароля. Следует помнить, что вряд ли вы найдете коммерческую версию программы на FTP-сервере, но тестовые версии программ, а также свободно распространяемые про­граммы вы там найдете. Различают два типа программ, которые вы можете на законных основаниях скопировать себе через Интернет.

Свободно распространяемые программы – freeware. Программы этого типа распространяются бесплатно и вы, на совершенно законном основании, можете их копировать и ис­пользовать. Иногда имеются некоторые условия, которым вы обязаны следовать, например, копировать можно только целиком пакет про­грамм, а не отдельные его части. К свободно распространяемым про­граммам относится Internet Explorer, FTP-клиент Leech FTP.

Условно-бесплатные программы – shareware. Данные программы распространяются бесплатно, и вы можете попробовать их в работе, но для законного использования этих программ вы должны заплатить не­которую сумму. Чаще всего это небольшая сумма в несколько долларов. В некоторых случаях после оплаты вы регистрируете программу, то есть вводите специальный регистрационный код, получаемый после перево­да необходимой суммы, и получаете некоторые дополнительные воз­можности. К данному типу программ относится текстовый редактор Aditor, архиваторы WinZip, WinRAR, FTP- клиент CuteFTP.

Концепция условно-бесплатных программ не получила достаточного распространения в нашей стране. Это обусловлено не только повсеместным использованием незаконных копий программ, но и объективными причи­нами. Добросовестному пользователю будет достаточно сложно перечис­лить десять долларов на счет в США, используя услуги отечественных банков. Возможно, стоимость перевода превысит сумму перечисляемых денег. В Интернет распространена оплата с использованием пластиковых карт, но они также недостаточно распространены у нас в стране.

Для получения файлов из Интернет можно использовать универсальные программы, такие как Internet Explorer или Netscape Navigator, но в неко­торых случаях удобнее воспользоваться специальной программой для пе­редачи файлов. Существует множество таких программ, мы рассмотрим использование программы FAR.


6.3. Работа с FTP доступом


Для подключения к удаленному каталогу на FTP сервере нажмите клавиши Alt F1 или Alt F2. В появившемся окне выберите пункт меню FTP и нажмите Enter. Щелчком мыши активизируйте окно FTP. Далее, для соединения с нужным вам FTP сервером, нажмите клавиши Shift F4. В окне Ввод адреса FTP в поле ftp://пользователь:пароль@сервер:порт/папка введите, соответственно, имя пользователя, через двоеточие пароль, через символ “@” имя FTP сервера, через двоеточие порт №21 и название каталога. Отметим, что порт и название каталога, как правило, не заполняется. Если вы ввели пароль в поле ftp://пользователь:пароль@сервер:порт/папка, то поле Пароль можно проигнорировать. Поле Описание FTP служит для ввода любой информации по желанию пользователя. Вкладка спрашивать пароль непосредственно перед подключением является необходимой, если вы желаете сохранить секретность доступа к FTP-серверу. Естественно, что заполнение данной вкладки имеет смысл в том случае, когда в поле ftp://пользователь:пароль@сервер:порт/папка пароль не введен. Поле Текстовый режим позволяет использовать по умолчанию текстовый режим пересылки файлов. Поле Пассивный режим предназначено для работы с некоторыми типами firewall. Поле Использовать firewall предназначено для ввода имени firewall сервера. Кнопка Сохранить позволяет сохранить введенное в поле ftp://пользователь:пароль@сервер:порт/папка название FTP-сервера в списке серверов, отображаемых на FTP панели. Кнопка Соединить предназначена для осуществления текущего соединения, без сохранения имени FTP-сервера в списке серверов, отображаемых на FTP панели. Кнопка Выбрать таблицу позволяет установить кодировку для данного сервера взамен используемой по умолчанию. Следует отметить, что при использовании режима Сохранить, пользователь получает возможность редактировать параметры сервера (изменить имя пользователя, пароль, название сервера и т.д.). Для этого необходимо нажать клавишу F4, внести все необходимые изменения и щелкнуть по кнопке Соединить.

Рассмотрим пример подключения к FTP-серверу fio.ifmo.ru, пользователя с1u1. В поле ftp://пользователь:пароль@сервер:порт/папка вводим:

с1u1:c1u1fio@fio.ifmo.ru:21

и выбираем кнопку либо Сохранить, либо Соединить.


6.4. Передача файлов по сети


В данном разделе рассмотрим проблему пересылки файлов с вашего компьютера на удаленный сервер.

Копирование каталога или файла с локального диска на удаленный осуществляется следующим образом:

  • осуществите подключение к FTP-серверу;

  • активизируйте панель локального диска;

  • выделите с помощью курсора файл или каталог, подлежащие копированию и нажмите клавишу F5.

Копирование каталога или файла с удаленного диска на локальный проводится аналогичным образом с той лишь разницей, что в качестве активной панели выступает удаленный диск.

Переименование и пересылка файлов и каталогов осуществляется с использованием клавиши F6.


6.5. Поиск файла на FTP-сервере


Поиск файла на FTP-сервере осуществляется следующим образом:

  • перейдите на интересующий вас FTP-сервер;

  • нажмите клавиши Alt F7;

  • в окне Поиск файла выберите поле Одна или несколько масок файлов, разделенных запятыми и введите параметры искомого файла;

  • выберите (по вашему усмотрению) флаги: Учитывать регистр и Использовать все таблицы символов;

  • в последующих полях выберите интересующий вас способ поиска и щелкните по кнопке Искать.

6.6. Задание


  1. Осуществите подключение к следующим FTP-серверам: aco.ifmo.ru; ftp.ifmo.ru; ftp.runnet.ru.

  2. Используя поисковую систему программы FAR, на сервере ftp.ifmo.ru найдите все файлы с расширением mpg и скопируйте некоторые из них на ваш локальный диск.

  3. Осуществите соединение с вашим FTP-сервером, используя режим спрашивать пароль непосредственно перед подключением. Для этого проделайте следующие действия:

  • в поле ftp://пользователь:пароль@сервер:порт/папка введите имя учебного FTP-сервера (т.е. fio.ifmo.ru);

  • выберите вкладку спрашивать пароль непосредственно перед подключением;

  • нажмите Сохранить;

  • переведите курсор на каталог (папку) fio.ifmo.ru и нажмите Enter;

  • в появившемся окне Информация о пользователе заполните соответствующие поля.

  1. Активизируйте панель FTP и отредактируйте запись fio.ifmo.ru таким образом, чтобы подключение к вашему FTP-серверу происходило без запроса имени и пароля пользователя.

  2. С помощью встроенного редактора FAR создайте текстовый файл под названием index.html, содержащий следующий текст в кодировке KOI8-R:






Заголовок окна





Название документа













Заголовок таблицы
Левая колонка Правая колонка
1   2   3   4   5   6

Похожие:

Компьютерные сети и Интернет Учебно-методическое пособие icon«Компьютерные сети, интернет и мультимедиатехнологии»
Рабочая учебная программа по дисциплине «Компьютерные сети, интернет и мультимедиатехнологии» для ооп «050100 Педагогическое образование...
Компьютерные сети и Интернет Учебно-методическое пособие iconУчебно-методическое пособие по курсу системы и сети связи
Галуев Г. А. Принципы построения и основы функционирования систем и сетей связи: Учебно-методическое пособие
Компьютерные сети и Интернет Учебно-методическое пособие iconМаксимов Н. В., Попов И. И. Компьютерные сети: Учеб пособие. 3-е изд
Компьютерные сети: Учеб пособие. 3-е изд., испр и доп. М.: Форум, 2008. 448 с.: ил. (Профессиональное образование), переплет, тираж...
Компьютерные сети и Интернет Учебно-методическое пособие iconУчебно-методическое пособие предназначено для освоения студентами 1 и 2 курсов университета всех форм обучения и всех специальностей основ работы в сети Интернет и выполнения лабораторных работ по дисциплинам «Информатика»
Учебно-методическое пособие предназначено для освоения студентами 1 и 2 курсов университета всех форм обучения и всех специальностей...
Компьютерные сети и Интернет Учебно-методическое пособие iconУчебно-методический комплекс по дисциплине дпп ф. 08 «Компьютерные сети. Интернет. Мультимедиа»
Федеральное государственное образовательное учреждение высшего профессионального образования
Компьютерные сети и Интернет Учебно-методическое пособие iconУчебно-методический комплекс по дисциплине дпп ф. 08 «Компьютерные сети. Интернет. Мультимедиа»
Федеральное государственное образовательное учреждение высшего профессионального образования
Компьютерные сети и Интернет Учебно-методическое пособие iconУчебно-методический комплекс по дисциплине дпп ф. 17 «Компьютерные сети. Интернет. Мультимедиа»
Федеральное государственное образовательное учреждение высшего профессионального образования
Компьютерные сети и Интернет Учебно-методическое пособие iconУчебно-методическое пособие «Создание образовательных ресурсов в сети Интернет» Санкт-Петербург
Пособие написано для тьюторов районных центров ит, а также работников образования, готовых использовать преимущества новых информационных...
Компьютерные сети и Интернет Учебно-методическое пособие iconПравила использования сети Интернет в мосш №11 1
Использование сети Интернет в образовательном учреждении направлено на решение задач учебно-воспитательного процесса
Компьютерные сети и Интернет Учебно-методическое пособие iconВ сети интернет учебно
Целью изучения дисциплины «Основы работы в сети Интернет» является подготовка студентов к самостоятельной работе в сети с использованием...
Разместите кнопку на своём сайте:
Библиотека


База данных защищена авторским правом ©lib.znate.ru 2014
обратиться к администрации
Библиотека
Главная страница