Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение




НазваниеБаталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение
страница9/18
Дата30.09.2012
Размер2.08 Mb.
ТипУчебное пособие
1   ...   5   6   7   8   9   10   11   12   ...   18

2.2. Базовые возможности табличных процессеров

2.2.1 Запуск табличного процессора MS Excel


Для запуска электронной таблицы нажмите кнопку Пуск на панели задач, которая обычно находится в нижней части экрана, и выполните команды Программы, Microsoft Office, Microsoft Excel.

В результате запуска приложения MS Excel на экране появляется окно программного продукта и файл, называемый по умолчанию Книгой.

2.2.2. Интерфейс пользователя табличного процессора MS Excel


Окно MS Excel имеет в верхней части строку заголовка, главное меню и панели инструментов с кнопками для выполнения различных команд. По умолчанию показываются панели Стандартная и Форматирование. Если нужная Вам панель отсутствует, то ее можно вывести на экран выполнив команду меню Вид, Панели инструментов и установив напротив названия панели флажок. В нижней части окна MS Excel находится строка состояния. В центральной части окна MS Excel расположено окно рабочего листа. Рабочий лист (worksheet) представлен в виде области ячеек, в которые вы можете вводить информацию при создании электронной таблицы. Заголовки столбцов рабочего листа нумеруются буквами латинского алфавита, а заголовки строк - арабскими цифрами, рисунок 2.2.1.

Область пересечения строк и столбцов называется ячейкой. При перемещении указателя мыши в область рабочего листа он из стрелки преобразуется в жирный белый крестик.

Окно MS Excel содержит следующие элементы:

  • заголовки строк и столбцов. Щелчок по заголовку позволяет выделить соответствующую строку или столбец целиком. Поставив указатель мыши на линию между областями (указатель примет вид черты с поперечными стрелками), можно изменить высоту строки или ширину столбца.

  • кнопки для смены листов. Щелчок по кнопке позволяет прокручивать список листов, либо выбирать требуемый лист в контекстном меню со списком всех листов рабочей книги;

  • ярлычки листов. Щелчок по ярлычку листа левой кнопкой мыши делает выбранный лист текущим, щелчок правой - откроет контекстное меню, позволяющее выполнить операции с рабочим листом: переименовать, скопировать лист, удалить лист и т. д.


Рис. 2.2.1 Вид рабочего окна процессора MS Excel


  • маркер. Перемещение маркера позволяет изменять и количество одновременно доступных ярлычков листов.

  • маркер разделения. Перемещение маркера позволяет разбить окно по вертикали на две области, каждая со своей отдельной полосой горизонтальной прокрутки. Таким образом, становится возможным видеть две несмежные области таблицы. Над полосой вертикальной прокрутки находится второй маркер разделения, который позволяет разбить окно по горизонтали. Если эти два маркера использовать одновременно, тогда в каждой из четырех областей можно будет независимо устанавливать свой фрагмент электронной таблицы. Границы разделения можно сдвигать или убирать зацепив их курсором мыши.

2.2.3. Представление данных в электронной таблице


При создании электронной таблице данные заносятся в ячейки, образуемые на пересечении столбцов и строк. Столбцы помечены буквами латинского алфавита (A, B, C, D, ... Z, AA, AB, AC, AD, ... AZ, BA, BB, BC, и т.д.), а строки пронумерованы арабскими цифрами (1,2,3,…).

Типы данных

В MS Excel используются следующие типы данных: строковый(текст), числовой, логический, массивы и структуры.

Текст - последовательность, состоящая из любых символов, например букв алфавита, цифр, пробелов, знаков и не являющихся числом или формулой. Для определения числа как текста перед ним ставится апостроф, например ‘999.

Число последовательность цифр, которая может начинаться со знака + или - . Даты и время суток интерпретируются как числа. В MS Excel используется система отсчета дат с начала столетия; в этой системе числу 1 соответствует дата 1 января 1900 г. Чтобы изменить систему отсчета дат, выберите команду меню Сервис, Параметры, а затем – вкладку Вычисления. В группе Параметры книги установите флажок Система дат 1904.

Данные логического типа имеют значение ИСТИНА или ЛОЖЬ и используются при создании условий.

Массивы и структуры данных создаются специальными средствами MS Excel и имеют вид таблиц.

Выделение ячеек

К данным в электронной таблице обращаются по адресу ячейки, который состоит из номера столбца и строки, например А2. Все операции с данными (ввод, копирование, удаление и т.д.) в MS Excel производятся для выделенных ячеек.

Для выделения ячейки достаточно установить на неё указатель мыши (курсор) и щелкнуть левой кнопкой мыши. Во время выделения ячеек курсор имеет вид жирного белого крестика. Ячейки выделяются (активизируются) также при перемещении по электронной таблице с использованием курсорных клавиш и клавиши Tab.

Для выделения прямоугольного блока из нескольких ячеек (диапазона ячеек) достаточно установить указатель на ячейку в одном из углов блока, нажать левую кнопку мыши и не отпуская протащить указатель по диагонали блока, рисунок 2.2.2.





Рис. 2.2.2 Выделения ячейки, фрагментов и цельного блока ячеек


Прямоугольный блок выделяется также с использованием комбинации Shift + курсорные клавиши. Диапазон ячеек обозначается адресами ячеек левого верхнего и правого нижнего углов прямоугольного блока, например А3:С5.

Ввод и редактирование данных

Для ввода данных в ячейку необходимо:

  • выделить ячейку;

  • набрать на клавиатуре текст, число или формулу;

  • нажать клавишу Enter, либо Tab, либо кнопку Enter в строке формул.

Для редактирования содержимого ячейки необходимо:

  • установить указатель на ячейку,

  • выполнить двойной щелчок левой кнопкой мыши, либо выделить ячейку, нажать клавишу F2 или щелкнуть по строке формул.

В режиме редактирования можно исправить часть текста или формулу в ячейке. Завершается редактирование данных нажатием клавиши Enter, либо Tab или кнопки Enter в строке формул, рисунок 2.2.3

Нажатие клавиши Esc или кнопки Отмена в строке формул отменяет вводимые изменения содержимого ячейки.





Рис. 2.2.3 Кнопки Enter и Esc в строке формул


Отменить выполненные операции можно нажимая кнопку отмена на Стандартной панели инструментов.

Для удаления данных в ячейке необходимо:

  • выделить ячейку;

  • нажать клавишу Del.

Выделенную ячейку или диапазон ячеек можно очистить командой меню Правка, Очистить. При этом предлагается очистить Все, либо Форматы, либо Содержимое (Del), либо Примечания.

Ввод текста

Введенный в ячейку текст выравнивается по умолчанию по левому краю ячейки. Если текст не помещается в ячейку, то он показывается поверх следующих справа пустых ячеек, либо показывается часть текста (по размеру ячейки), если ячейка справа содержит данные. Дважды щелкните на правой границе заголовка столбца, чтобы ширина столбца соответствовала самой длинной записи в ячейке или дважды щелкните на нижней границе заголовка строки, чтобы высота строки соответствовала наибольшей высоте введенных символов.

MS Excel позволяет проверять орфографические ошибки. Для этого: Выделите диапазон ячеек, в которых необходимо проверить орфографию, либо укажите одну ячейку, чтобы проверить орфографию на всем листе.

Выполните команду меню Сервис, Орфография или нажмите кнопку Орфография на Стандартной панели инструментов.

При вводе нескольких первых букв в ячейку MS Excel использует прием автозаполнения: автоматически завершает ввод всего текста, предлагая поместить текст, введенный ранее в этот столбец. Для этого должен быть включен режим Автозавершение значений ячеек на вкладке Правка, в команде меню Сервис, Параметры.

MS Excel позволяет производить автозамену. Автозамену можно использовать для ускорения ввода часто встречающихся фраз. Например, для автозамены символов «К4» после их ввода на текст «IV квартал» выполните команду меню Сервис, Параметры автозамены, Автозамена. В окне Автозамена, рисунок 2.2.4, введите символы и текст, на который требуется их заменить, затем нажмите кнопку Добавить.





Рис. 2.2.4 Окно диалога "Автозамена"


MS Excel имеет специальную возможность автозаполнения по списку. Для этого введите в ячейку одно из слов, содержащихся в специальном списке, например, Январь. Выделите данную ячейку, затем установите указатель мыши в правом нижнем углу ячейки (указатель примет вид черного крестика – маркера заполнения «+», рисунок 2.2.5).






Рис. 2.2.5 Отображение маркера заполнения в правом/нижнем углу ячейки


Нажмите левую кнопку мыши и протащите маркер «+» на несколько ячеек. Ячейки заполнятся названиями месяцев. Список при автозаполнении циклически повторяется если диапазон выделенных ячеек превышает число элементов списка, рисунок 2.2.6.





Рис. 2.2.6 Процесс автозаполнения ячеек листа


Списки можно дополнить, выполнив команду Сервис, Параметры, на вкладке Списки ввести новые Элементы списка и нажать кнопку Добавить, рисунок 2.2.7





Рис. 2.2.7 Списки автозаполнения в окне диалога


Ввод чисел

Число - последовательность цифр, которая может начинаться со знака + или - . Если числовые данные не помещаются в ячейку, то в зависимости от ширины ячейки число преобразуется к экспоненциальному формату, либо округляется, либо ячейка заполняется знаками #######. Для увеличения ширины ячейки установите указатель на правой границе заголовка столбца и нажав левую кнопку мыши протащите его до нужного размера ширины столбца. В MS Excel для отделения дробной части числа применяется запятая.

Для ввода даты используйте точку или дефис в качестве разделителя, например, 09.05.06 или Янв-06, рисунок 2.2.8. Для отображения времени суток в 12-часовом формате введите букву a или p, отделенную пробелом от значения времени, например 9:00 p. В противном случае время будет интерпретировано на основе 24-часового формата. При вводе значений даты или времени происходит их автоматическое распознавание, и общий формат ячейки заменяется на встроенный формат даты или времени. По умолчанию значения даты и времени, как и числа, выравниваются в ячейке по правому краю. Если не происходит автоматического распознавания формата даты или времени, то введенные значения интерпретируются как текст, который выравнивается в ячейке по левому краю.

Заполнение ячеек числами можно производить с использованием маркера заполнения. Введите в ячейку число, например 8. Выделите данную ячейку и установите указатель мыши в правый нижний угол ячейки так, чтобы он принял форму черного крестика «+» Нажмите левую кнопку мыши и не отпуская ее протащите маркер заполнения «+» на несколько ячеек. Ячейки заполнятся значениями числа 8, т.е. данные из исходной ячейки копируются.





Рис. 2.2.8 Представление различной информации в ячейках листа


Другой эффект получается при автозаполнении на основе выделенного диапазона данных в нескольких ячейках. При этом MS Excel использует линейную экстраполяцию данных. Это позволяет производить экстраполяцию ряда данных для получения краткосрочного прогноза на будущее. Создайте таблицу, содержащую данные об объеме оказываемых услуг некоторой фирмы по кварталам за 2006–2007 годов.

Для приведенной таблицы необходимо спрогнозировать динамику роста объема на 2007 годы. Для этого выделим ячейки в колонках Квартал и Объем с данными за 2006 год. Установим указатель в нижний левый угол выделенной области так, чтобы он принял вид маркера заполнения. Протащим маркер заполнения «+» вниз на несколько ячеек. В результате новые ячейки автоматически заполнятся значениями линейной экстраполяции для данного набора начальных данных, рисунок 2.2.9.

Следует иметь ввиду, что если внести новые значения в начальные данные, то результат экстраполяции не изменится, так как в последующие ячейки заносятся не формулы, а значения.





Рис. 2.2.9. Линейная экстраполяция на базе первых трех значений


Более широкие возможности заполнения ячеек предоставляет MS Excel при протаскивании маркера заполнения «+» правой кнопкой мыши, рисунок 2.2.10. Выделим базовые ячейки, установим маркер «+» в правом нижнем углу выделенного диапазона и протащим маркер «+» правой кнопкой мыши на несколько ячеек. В появившемся контекстном меню можно выбрать различные команды для автозаполнения.





Рис. 2.2.10 Контекстное меню маркера заполнения


При этом команды заполнения по дням, месяцам и годам будут работать при заполнении диапазона с первой ячейкой, содержащей название какого-либо дня, месяца или года. Выбрав в контекстном меню команду Линейное приближение получим линейную последовательность данных. Аналогично повторим автозаполнение для команд Экспоненциальное приближение и Прогрессия (геометрическая с Автоматическим определением шага ), рисунок 2.2.11.





Рис. 2.2.11 Диалоговое окно прогрессии


В обеих случаях заполнения получим геометрическую прогрессию, рисунок 2.2.12 .





Рис. 2.2.12. Результат заполнения при геометрической прогрессии


При проведении расчетов в ячейке записывается формула по правилам, аналогичным используемым в алгебре. Операторами обозначаются операции, которые следует выполнить над операндами формулы. В MS Excel включено четыре вида операторов: арифметические, текстовые, а также операторы сравнения и операторы ссылок.

Если формула состоит из нескольких операторов, то действия выполняются в порядке увеличения приоритетов операторов. Если формула содержит функцию, то сначала вычисляется значение функции. Если формула содержит операторы с одинаковым приоритетом, то MS Excel обрабатывает операторы слева направо. Чтобы изменить порядок обработки операторов, расставьте круглые скобки.

Арифметические операторы используются для выполнения основных математических вычислений над числами, например сложение, вычитание, умножение. Результатом выполнения арифметической операции всегда является число.

Операторы сравнения используются для обозначения операций сравнения двух чисел. Результатом выполнения операции сравнения является логическое значение ИСТИНА или ЛОЖЬ.

Текстовый оператор «&» используется для обозначения операции объединения последовательностей символов в единую последовательность.

Адресные операторы или операторы ссылок объединяют диапазоны ячеек для осуществления вычислений.

Формула в MS Excel начинается со знака = и содержит выражения: числа, имена функций, ссылки на ячейки, соединенные знаками арифметических операций. Формула интерпретируется MS Excel как текст если первым символом является пробел или апостроф «'».

После ввода формулы, в ячейке выводится число - результат расчета, а формулу можно увидеть в строке формул. Для просмотра формул во всех ячейках выполните команду меню Сервис, Параметры, и на вкладке Вид и установите флажок формулы.

Ссылки на ячейки

Понятие «ссылка» является одним из основных при работе в среде электронной таблицы. Чтобы сослаться на ячейку необходимо указать в формуле ее адрес или имя. Если столбцы помечены латинскими буквами, а строки пронумерованы, то такие ссылки называются ссылками типа A1. Можно заменить буквы в заголовках столбцов на номера. Для этого выполните команду меню Сервис, Параметры и установите на вкладке Общие флажок Стиль ссылок R1C1.

Ссылка на активную ячейку выводится на экран в области ссылок, расположенной слева от строки формул. Ссылка однозначно определяет ячейку или группу ячеек рабочего листа. Ссылка указывает в каких ячейках находятся значения, которые нужно использовать в качестве аргументов формулы. С помощью ссылок можно использовать в формуле данные, находящиеся в разных местах рабочего листа, а также использовать значение ячейки в нескольких формулах.

Можно ссылаться на ячейки, находящиеся на других листах рабочей книги, например Лист2!$В$3, а также в другой рабочей книге, например [Книга3]Лист2!$В$3, или даже на данные другого приложения. Ссылки на ячейки других рабочих книг называются внешними. Ссылки на данные в других приложениях называются удаленными.

Ссылки бывают относительными (обозначаются, например А2 ) и абсолютными (обозначаются, например $А$2 ). Ссылка на имя ячейки по умолчанию является абсолютной ссылкой. Абсолютная ссылка всегда указывает постоянное местоположение ячейки или интервала ячеек. Относительные ссылки автоматически корректируется при копировании формул из одной ячейки в другую или перемещении ячеек с данными.

Расчеты с использованием адресов ячеек

Рассмотрим пример расчета с использованием адресов ячеек.

В ячейки А1 и А2 введем числа: 567 и 4,4. В ячейку В1 введем формулу =А1*А2. После ввода формулы в ячейке получим результирующее значение. После выделения ячейки в строке формул показывается формула.

При наборе адреса ячейки следует особое внимание уделить текущему шрифту. Имена столбцов таблицы обозначаются ЛАТИНСКИМ шрифтом. В случае ввода адреса ячейки русским шрифтом компьютер покажет на ошибку в формуле.

Наиболее простой способ ввода адреса ячейки - это в процессе ввода формулы не набирать адрес ячейки, а выделить ячейку, адрес которой указывается в формуле. В этом случае MS Excel вставит в формулу адрес выделенной ячейки, рисунок 2.2.13.





Рис. 2.2.13 Ввод адреса ячейки в формуле методом ее выделения


Выше мы рассмотрели ссылку в пределах одного рабочего листа. Но часто ссылки необходимо делать на ячейки в различных листах одной книги. Перейдите на Лист2 и в ячейку А2 введите формулу, например = 1000+. При наборе формулы перейдите на Лист1, выделите мышью ячейку В1 и нажмите Enter, либо продолжите ввод формулы. Ваша ссылка будет содержать номер рабочего листа с восклицательным знаком и адрес ячейки, например =1000+ Лист1!В1, рисунок 2.2.14.





Рис. 2.2.14 Ссылка на ячейку B1 листа 1


При работе с несколькими книгами иногда приходится ссылаться на ячейки в разных книгах. Чтобы сослаться на ячейки другой книги необходимо, чтобы она тоже была открытой. Для этого не выходя из программы MS Excel нужно открыть еще одну книгу, например, выполнить команду меню Файл, Открыть и указать имя книги. Для работы с двумя и более книгами удобно воспользоваться командой меню Окно, Расположить, Рядом. В данном случае все окна документов будут у вас перед глазами. Напомним, что существуют два типа окон: окно программного продукта и окно документа, которое помещается в окно программного продукта. В одно окно программного продукта может быть помещено несколько окон документов. Все имена открытых документов можно посмотреть в пункте меню Окно под выделенной чертой, для перехода к нужному документу, выберите указателем мыши имя документа.





Рис. 2.2.15 Ссылка на ячейку другой Книги


Итак, для ссылки на ячейку другой книги в процессе набора формулы перейдите в окно другой книги и выделите мышью нужную ячейку. Перейдите на исходный лист, с которого начинался ввод формулы. Ваша ссылка будет содержать номер рабочей книги в квадратных скобках, номер листа с восклицательным знаком и абсолютный адрес ячейки, например =444+[Книга1]Лист1!$В$3, рисунок 2.2.15.

Расчеты с использованием имен ячеек

Для ссылки на ячейку, группу ячеек, значение или формулу можно использовать имя (идентификатор). Формулы, использующие имена, легче воспринимаются и запоминаются, чем формулы, использующие адреса ячеек. При изменении структуры рабочего листа достаточно обновить ссылки лишь в одном месте - в определении имен, и все формулы, использующие эти имена, будут использовать верные ссылки. Можно получить доступ ко всем именам из любого рабочего листа с помощью окна имени в левой части строки формул.

Вы можете использовать автоматическое создание имен, при котором MS Excel создает имена на основе заголовков строк или столбцов таблицы. Для этого выделите диапазон ячеек с названиями имен и данными, например А1:В3, затем выполните команду меню Вставка, Имя, Создать. В окне диалога проверьте расположение имен и нажмите ОК, рисунок 2.2.16.

Если ячейка имеет имя, то после ее выделения в поле Имя появляется не адрес ячейки, а ее имя.

Можно также вводить имя выделенного фрагмента в поле имя в левой части строки формул.





Рис.2.2.16 Диалоговое окно для создания имени для группы ячеек


Введите формулу для расчета амортизационных отчислений =АПЛ. При вводе аргументов выделяйте ячейки с данными, либо точно набирайте имена ячеек, рисунок 2.2.17.





Рис.2.2.17. Автоматический ввод имен ячеек

в качестве аргументов функции при выделении ячейки со значением


После ввода формулы в ячейке В4 получим результат расчета.

Использование функций листа MS Excel

Кроме функций, задаваемых пользователем, EXCEL содержит тринадцать групп функций листа:

  • финансовые;

  • дата и время;

  • математические;

  • статистические;

  • ссылки и массивы;

  • работа с базой данных;

  • тестовые;

  • логические;

  • проверка свойств значений;

  • инженерные;

  • информационные;

  • математика и тригонометрия

  • определенные пользователем

Все функции используют одинаковые основные правила синтаксиса. Если Вы нарушите правила синтаксиса, MS Excel выдаст сообщение о том, что в формуле имеется ошибка. Если функция появляется в самом начале формулы, ей должен предшествовать знак равенства, как и во всякой другой формуле. Список аргументов функции заключается в скобки. При этом не следует вставлять пробелов ни перед ними, ни после них. В качестве аргументов можно использовать числа, текст, логические значения, массивы, значения ошибок или ссылки. Задаваемые аргументы должны иметь допустимые для данного аргумента значения. Некоторые функции могут иметь необязательные аргументы, которые могут отсутствовать при вычислении значения функции. Аргументы могут быть как константами, так и формулами. В свою очередь эти формулы могут содержать другие функции. Функции, являющиеся аргументом другой функции, называются вложенными. В формулах Microsoft Excel можно использовать до семи уровней вложенности функций.

Встроенная функция (функции листа) чаще всего содержит список аргументов, которые надо вводить через точку с запятой после набора в строке функций ее имени. Если Вы затрудняетесь в правильном написании имени функции и ее аргументов, то можете воспользоваться мастером функций, рисунок 2.2.18. Для этого необходимо выполнить команду меню Вставка, Функция или нажать на кнопку Вставка функции на Стандартной панели инструментов.

Далее появившейся мастер функций подскажет назначение данной функции и откроет окна для ввода параметров.

Формат электронной таблицы

Форматирование заключается в выборе формата данных и оформлении вида ячеек. Excel позволяет:

  • назначать ячейке формат данных (числовой, финансовый, временной, даты и др.);

  • выравнивать данные в ячейке и изменять размеры ячеек;

  • изменять тип, размер, начертание и цвет шрифта;

  • оформлять обрамление и заливку ячеек.



Форматирование можно выполнять используя кнопки панели инструментов Форматирование или команды меню Формат, Ячейки.





Рис. 2.2.18 Диалоговое окно выбора функций листа


Наиболее просто выполнять форматирование с использованием кнопок.

Для форматирования ячеек с необходимо их выделить и нажать нужные кнопки на панели инструментов Форматирование

На панели инструментов Стандартная расположена кнопка для копирования форматов.




Копирует только форматы выделенных ячеек или объектов. Для копирования формата надо выделить исходную ячейку, нажать кнопку Формат по образцу, а затем выделить одну или несколько ячеек, в которые копируется формат.


Широкие возможности для форматирования ячеек можно предоставляют команды меню Формат, Ячейки. Эти команды расположены на шести вкладках, рисунок 2.2.19.





Рис. 2.2.19 Диалоговое окно Формат ячеек


Вкладка Число открывает доступ к группе форматов, в том числе и к текстовому. Общий формат является универсальным для чисел и текста в нем данные представлены в том виде, как они набраны. В текстовом формате все введенные данные будут интерпретироваться как текст. С помощью денежного формата пользователь может выбирать количество знаков после запятой, устанавливать или отменять сокращение слова «рублей» после цифр, выделять красным цветом отрицательные величины.

Вкладка Выравнивание предлагает команды для выравнивания по высоте и ширине ячейки, объединения ячеек, а также наклона надписи в ячейке.

Вкладка Шрифт позволяет выбрать тип, размер и начертание шрифта.

Вкладка Граница используется для обрамления ячейки при создании таблиц. Здесь можно задавать различные типы и цвет линий.

Вкладка Вид позволяет изменить цвет фона ячейки.

Вкладка Защита используется для снятия защиты от изменений для выделенной части ячеек при защите всего рабочего листа.

Для применения группы форматов используются стили. С помощью команды Стиль из меню Формат можно применить стили, которые поставляются с MS Excel. Можно создать собственные стили.

Копирование и перемещение объектов

В Windows установлено следующее правило: для того чтобы обработать данные, их нужно сначала выделить. Выделение ячеек используется для ввода, копирования, переноса и удаления данных, помещения ссылок на ячейки в формулы и окна диалога.


Работа с буфером обмена

Команды меню Правка: Вырезать, Копировать и Вставить позволяют осуществлять передачу данных через буфер обмена. Эти команды удобны для переноса блоков ячеек с данными с одного листа на другой в пределах одной рабочей книги, а также из одной книги в другую. Для копирования данных необходимо:

  • выделить ячейки с данными,

  • выполнить команду меню Правка, Копировать(для перемещения - Вырезать),

  • перейти на нужный лист(книгу) и выделить ячейку для вставки нового блока,

  • выполнить команду меню Правка, Вставить.

Выделенную ячейку или блок можно копировать в буфер обмена, нажав кнопку Копировать на Стандартной панели инструментов. Затем выделив ячейку левого верхнего угла нового блока нажать кнопку Вставить.

Команда меню Правка, Специальная вставка используется в тех случаях, процесс копирования данных соединяется с операциями их преобразования по различным алгоритмам, а также при вставке данных из других приложений, рисунок 2.2.20.








Рис. 2.2.20 Кнопки для работы с буфером обмена и диалоговое окно

Специальная вставка


Для перемещения данных в выделенной ячейке (блоке) используется кнопка Вырезать, затем выделяется ячейка для вставки и нажимается кнопка Вставить.

Команда меню Правка, Переместить/скопировать лист, позволяет перемещать и копировать листы в пределах данной книги, а также в другую книгу. Для копирование листа в окне диалога установите флажок Создавать копию, в противном случае выполняется перенос листа. Если же копирование происходит в пределах одной книги, то Excel добавляет к имени листа порядковый номер в скобках.

Прием Drag & Drop при копировании и перемещении данных

Excel позволяет копировать и перемещать ячейки и объекты используя приемы перетаскивания Drag & Drop (зацепил и тащи), рисунок 2.2.21.

Выделите блок ячеек. Для перемещения блока установите курсор на границу выделения - он должен превратиться в белую стрелку, направленную влево и вверх. После этого можно перетаскивать выделенный блок на новое место. Во время этой операции левая кнопка мыши должна быть нажата. Новое положение блока ячеек обозначается штриховой рамкой. Если в процессе перетаскивания вы приблизитесь к вертикальной или горизонтальной границе окна, то программа будет прокручивать рабочий лист соответственно по вертикали или по горизонтали, показывая невидимые до сих пор области. Как только вы отпустите кнопку мыши, блок ячеек встанет на новое место.





Рис. 2.2.21 Реализация технологии Drag & Drop


Если при перемещении выделенного блока ячеек держать нажатой клавишу Alt, то его можно перенести на другой лист. Для этого необходимо поместить штриховую рамку, обозначающую выделение, на ярлычки листов и добиться прокрутки листов в нужном направлении.

Для копирования данных выделите ячейку (блок), установите указатель (в виде стрелки) на нижней границе ячейки (блока), нажмите клавишу Ctrl и не отпуская её, перетащите содержимое ячейки левой кнопкой мыши в новую ячейку. О том, что происходит копирование свидетельствует маленький знак «плюс», который добавляется к изображению курсора. Отпустите сначала кнопку мыши, а затем клавишу Ctrl . Если вы будете одновременно удерживать в нажатом состоянии клавиши Alt и Ctrl, то сможете скопировать выделенный фрагмент на другой лист.

Аналогично можно копировать или перемещать выделенную ячейку (блок) протаскиванием правой кнопкой мыши. При этом в контекстном меню выберите нужную команду, рисунок 2.2.22. Команды меню позволяют выбрать режим копирования или перемещения данных. Команда Копировать форматы запрещает копирование данных. Соответственно, команда Копировать значения копирует данные, но не копирует формулы и форматы.





Рис. 2.2.22 Контекстное меню при перемещении блока ячеек на листе


В случае переноса данных в массив старая информация автоматически уничтожится, но может возникнуть ситуация, когда новые данные нужно поместить в массив уже существующих. Например, вставить новые строки в таблицу. Последние четыре команды контекстного меню, предназначены для того, чтобы сначала сдвинуть часть рабочего листа в заданном направлении, освобождая место, а затем поместить в него новые данные.

Если экран разбит на два окна, то данные можно перетащить прямо в другое окно без нажатой клавиши Alt. Только делать это надо быстро, чтобы программа не включила прокрутку текущего листа.

MS Excel позволяет копировать ячейку или линейный блок ячеек (в столбце/строке) с использованием маркера заполнения «+» .

Для этого выделите ячейку, установите указатель в правом нижнем углу ячейки и протащите маркер « левой кнопкой мыши, захватив несколько ячеек. Таким способом можно, например, ячейку скопировать в столбиковый блок, а столбик - в прямоугольный блок, рисунок 2.2.23.





Рис. 2.2.23. Заполнение блока с помощью маркера заполнения


Модификация формул при копировании и перемещении ячеек

Рассмотрим примеры копирования и перемещения ячеек при проведении расчетов с использованием относительных и абсолютных ссылок на адреса ячеек.


Начиная с ячейки В4 вниз по столбцу введем значения: 4,6,8, а начиная с ячейки D5 вниз по столбцу введем значения: 5,2,6. В ячейку F6 введем формулу =B4+D5.

Выделите ячейку F6 и установите указатель мыши в правый нижний угол ячейки. При появлении черного крестика (маркера заполнения) нажмите на левую клавишу мыши и не отпуская ее протяните вниз, до ячейки F8. Произойдет заполнение ячеек результатом вычисления по модифицированным формулам: в ячейке F7 =B5+D6 в ячейке F8 =B6+D7. Таким образом, при копировании ячейки с формулой, относительные ссылки на влияющие ячейки изменились согласно смещению копируемой ячейки, рисунок 2.2.24.







Рис. 2.2.24 Относительная ссылка на ячейки листа


Если требуется проанализировать формулы на рабочем листе, то выполните команду меню Сервис, Параметры и на вкладке Вид установите флажок формулы. MS Excel позволяет показать стрелками зависимости между данными и результатами. Для этого выделите ячейку с формулой выполните команду меню Сервис, Зависимости формул, Влияющие ячейки. Ячейки соединятся линиями, указывающими на расположение исходных данных.

Выясним, что происходит с абсолютной ссылкой при копировании формулы. Начиная с ячейки B2 вниз по столбцу введем следующие числа: 4,6,8. Начиная с ячейки Е2 вниз по столбцу введем числа: 5,2,6. В ячейку С7 введем формулу =$B$2+Е2, рисунок 2.2.25.

Эта формула отличается от формулы, рассмотренной выше тем, что при ее написании мы использовали абсолютную ссылку на ячейку B2.

Маркером заполнения скопируем формулу из ячейки С7 в диапазон ячеек С8:С9. Для наглядного анализа полученного результата выполним команду меню Сервис, Зависимости формул, Влияющие ячейки и получим линии, указывающие на расположение исходных данных. Таким образом, при копировании ячейки с формулой, абсолютные ссылки на влияющие ячейки не изменились. Следовательно, для закрепления адреса ячейки в формуле необходимо использовать знак доллара $. Можно по отдельности закреплять номер столбца, например $В2 или строки, например В$2.





Рис. 2.2.25 Абсолютная ссылка на ячейку B2 и относительная на ячейки E2:E4


Рассмотрим пример модификации формулы при перемещении ячеек с данными, рисунок 2.2.26 . В ячейки А1, А2, А3 введем числа 5, 6, 7. В ячейку С2 введем формулу = А1+А2+А3. При переносе ячейки с формулой ссылки на адреса ячеек не изменяются. Перенесем исходные данные, т.е. ячейки А1:А3 в диапазон В2:В4. Для этого выделим диапазон ячеек А1:А3, выполним команду меню Правка, Вырезать. Выделим ячейку В2 и выполним команду меню Правка, Вставить. Формула в ячейке С2 изменилась соответственно перемещению данных и имеет вид=В2+В3+В4.





Рис. 2.2.26 Модификации формулы при перемещении ячеек с данными


Таким образом, MS Excel отслеживает изменение адресов ячеек с данными и модифицирует формулы, использующие ссылки на эти ячейки.

2.2.4. Сохранение результатов работы


Файл, созданный MS Excel, по умолчанию называется Книгой и имеет расширение имени файла .XLS. Если вы будете создавать новые файлы (нажимая кнопку Создать на стандартной панели инструментов), то MS Excel будет присваивать им по умолчанию следующие имена: Книга2, КнигаЗ и т. д. До тех пор, пока Вы не выполните команду Файл, Сохранить (удобнее нажимать кнопку Сохранить), набранная информация не будет записана на диск и Вы рискуете ее потерять при сбое или перезагрузке компьютера. При первом сохранении файла с именем Книга1(а также Книга2 Книга3 и т.д.) MS Excel предложит Вам переименовать файл. В других случаях для переименования рабочей книги выберите команду Файл, Сохранить как, в появившемся окне Сохранение документа введите имя новой рабочей книги и директорию. В результате выполнения этой операции в выбранной директории появится файл рабочей книги.

Команда Сохранить как является, по сути, средством копирования файлов. По этой команде закрывается старый файл (без модификации содержимого) и открывается его копия. Имена открываемых файлов запоминаются программой и изображаются в нижней части меню Файл с указанием полного пути. Причем к файлам, находящимся в текущей директории, путь не показывается. Двойным щелчком пользователь может впоследствии быстро открыть нужный файл.

В окне Сохранить как имеется кнопка Параметры, нажав которую Вы увидите окно Параметры Сохранения.

Установив флаг Всегда создавать резервную копию, вы обеспечиваете создание копии сохраняемого файла, например Резервная копия Книгаl.xlk.

Следующие параметры - это строки для ввода паролей при открытии файла и разрешения записи в файл.

Четвертый параметр - флаг Рекомендовать доступ только для чтения. Если этот флаг установлен, то при открытии файла программа предложит пользователю сделать выбор: разрешить или запретить запись в файл во время работы с ним.

Команда меню Файл, Сохранить рабочую область позволяет сохранить вид экрана и настройки системы с тем, чтобы иметь возможность продолжить работу в заданной конфигурации. Файлы рабочих областей имеют расширение имени файла .XLW.

Команда меню Файл, Свойства открывает одноименное окно, в котором можно получить информацию о свойствах текущей книги (когда и кем создана книга, что она содержит и т. д.).

Команда меню Файл, Сохранить в формате HTML предназначена для создания с помощью мастера из вашего файла WEB страницы.

2.2.5. Открытие файлов рабочих книг


Допустим, окно приложения MS Excel открыто. Если Вы случайно закрыли файл, с которым работали или Вам нужно открыть какой либо другой файл электронной таблицы, выполните команду меню Файл, Открыть. В окне Открытие документа выберите папку, имя файла и нажмите кнопку Открыть, либо выполните двойной щелчок левой кнопкой мыши на значке документа, созданного MS Excel.

2.2.6. Завершение работы с MS Excel


После окончания работы с книгой Вы можете закрыть файл командой меню Файл, Закрыть. Если Вы завершаете работу с приложением MS Excel, то в меню Файл выберите команду Выход. Напомним, что быстро закрыть окно приложения можно нажав кнопку Закрыть (расположенную в верхнем правом углу окна) или нажав комбинацию клавиш ALT+F4. Если какие-то из открытых рабочих книг содержат не сохраненные изменения, то MS Excel выдаст сообщение, предлагающее сохранить изменения перед тем, как закрыть рабочие книги. Нажмите кнопку Да, чтобы сохранить изменения, кнопку Нет, чтобы завершить работу, не сохраняя изменений, или кнопку Отмена, чтобы отменить команду выхода.


1   ...   5   6   7   8   9   10   11   12   ...   18

Похожие:

Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconЛекция 4 Программное
Новые термины и понятия: программа, программное обеспечение, базовое программное обеспечение, системное программное обеспечение,...
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconЛабораторная работа №7 по дисциплине «Прикладное программное обеспечение»
«Прикладное программное обеспечение» для студентов, обучающихся по специальности «Информационные системы и технологии»
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconРабочая программа по дисциплине «Системное и прикладное программное обеспечение» для специальности "Прикладная математика и информатика"
«Системное и прикладное программное обеспечение» для специальности "Прикладная математика и информатика"
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconПрограмма по дисциплине: информатика и применение компьютеров в научных исследованиях (Прикладное программное обеспечение). Продвинутый курс
Информатика и применение компьютеров в научных исследованиях (Прикладное программное обеспечение). Продвинутый курс
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconПрограмма по дисциплине: информатика и применение компьютеров в научных исследованиях (Прикладное программное обеспечение). Продвинутый курс
Информатика и применение компьютеров в научных исследованиях (Прикладное программное обеспечение). Продвинутый курс
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconПрограмма учебной дисциплины «Прикладное программное обеспечение»
Программа предназначена для преподавателей, ведущих данную дисциплину, учебных ассистентов и студентов направления 040100. 62 «Социология»...
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconПрограмма учебной дисциплины «Прикладное программное обеспечение»
Программа предназначена для преподавателей, ведущих данную дисциплину, учебных ассистентов и студентов направления 040100. 62 «Социология»...
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconПрограмма дисциплины «Прикладное программное обеспечение» для направления 040100. 62 «Социология»
Программа предназначена для преподавателей, ведущих данную дисциплину, учебных ассистентов и студентов направления подготовки/специальности...
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconУчебное пособие Липецк 2001 ноу «Липецкий эколого-гуманитарный институт» А. К. Погодаев > В. В. Дозоров Программное обеспечение автоматизированных систем. Разработка приложений баз данных
Программное обеспечение автоматизированных систем. Разработка приложений баз данных: Учебное пособие Липецк: лэги, 2002. 71 с
Баталов С. А., Исхаков З. Ф., Абросимова М. А. Информатика учебное пособие Часть 3 прикладное программное обеспечение iconЛекция Прикладное программное обеспечение
Назначение, состав и классификация прикладного по. Прикладное по общего назначения. Офисные программы. Программы работы с текстовыми...
Разместите кнопку на своём сайте:
Библиотека


База данных защищена авторским правом ©lib.znate.ru 2014
обратиться к администрации
Библиотека
Главная страница