Методические указания к лабораторным работам №1, 2 по дисциплине "Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств»




Скачать 403.39 Kb.
НазваниеМетодические указания к лабораторным работам №1, 2 по дисциплине "Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств»
страница1/2
Дата31.08.2012
Размер403.39 Kb.
ТипМетодические указания
  1   2
МИНИСТЕРСТВО ОБРАЗОВАНИЯ РОССИЙСКОЙ ФЕДЕРАЦИИ


Воронежский государственный технический университет


Кафедра конструирования и производства радиоаппаратуры


МЕТОДИЧЕСКИЕ УКАЗАНИЯ


к лабораторным работам №1, 2 по дисциплине "Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций"

для студентов специальности 210201 – «Проектирование

и технология радиоэлектронных средств» дневной формы обучения


Воронеж 2004


Составитель: канд. техн. наук И.К. Андреков,


УДК 681.3

Методические указания к лабораторным работам №1, 2 по дисциплине "Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций" для студентов специальности 210201 – «Проектирование и технология радиоэлектронных средств» дневной формы обучения / Воронеж. гос. техн. ун-т; Сост. И.К. Андреков. Воронеж, 2004. 28 с.



Методические указания предназначены для развития практических навыков работы с системой схемотехнического проектирования OrCAD при разработке приемопередающих устройств радиостанций. По лабораторным работам приводятся: краткие теоретические сведения, описание лабораторной программы, задание для самостоятельной работы, лабораторные задания.


Табл. 2. Ил. 10. Библиогр.: 10 назв.


Рецензент д-р техн. наук, проф. В.М. Питолин


Ответственный за выпуск зав. кафедрой КИПРА д-р техн. наук, проф. А.В. Муратов.


Печатается по решению редакционно-издательского совета Воронежского государственного технического университета


 Воронежский государственный

технический университет, 2004.


Лабораторная работа №1


СТРУКТУРА И ВОЗМОЖНОСТИ ПАКЕТА OrCAD.

СОЗДАНИЕ УСЛОВНЫХ ГРАФИЧЕСКИХ ОБОЗНАЧЕНИЙ.


1.ОБЩЕЕ ОПИСАНИЕ РАБОТЫ


1.1. Цель работы – изучение назначения, организации, функционирования возможностей пакета OrCAD и создание в нем принципиальной схемы.


1.2. Содержание работы


Лабораторная работа состоит из домашнего и лабораторного заданий. Домашнее задание заключается в изучении назначения и возможностей комплекса OrCAD, правил создания условных графических обозначений (УГО) на принципиальных схемах. Лабораторное задание включает создание условных графических обозначений в графическом редакторе схем OrCAD Capture.


1.3. Используемое оборудование


Для выполнения лабораторной работы используется ПЭВМ типа IBM PC, цветной монитор с графическим адаптером VGA и выше.


2. Домашнее задание и методические указания по его выполнению


По методическому руководству ознакомится с назначением, организацией и возможностями пакета OrCAD, правилами создания УГО в графическом редакторе схем OrCAD Capture.

2.1. Назначение и возможности пакета OrCAD


В середине 80 годов началось постепенная переориентация систем проектирования с больших и среднего класса ЭВМ на класс персональных компьютеров. Этот период времени характеризуется образо­ванием большого количества фирм разработчиков ПО САПР для персонального класса вычислительных машин. В 1985 году была осно­вана фирма OrCAD, специализация которой была направлена на со­здание САПРа схемотехнического проектирования. Разработчики ПО одни из первых осознали возможности ПЭВМ и все проблемы, свя­занные с использованием данного класса ЭВМ. Они одни из первых начали поставку защищенного от несанкционированного копирова­ния программного продукта, что привело к тому, что на территории бывшего СССР распространение получило программное обеспечение P-CAD, которое по многим параметрам в значительной мере уступало OrCADy.

OrCAD разрабатывал ПП как систему сквозного проектирования и уже в ранних версиях предусматривал возможность наращивания систе­мы с помощью специализированных пакетов моделирования (Pspice) фирмы MicroSim, впоследствии ставшей отделением OrCADa теплового анализа, представлявшую собой наиболее современную, мощную и удобную систему теплового анализа электронных устройств (BetaSoft) фирмы Dynamic SoftAnalisys,Inc. и анализа целостности проекта (т.е. оценки влияния конструктивных особенностей печатных плат на их электрические характеристики) и моделирования электромагнитной совместимости Omega PLUS фирмы Quantic EMC.

Что такое OrCAD — это интегрированное программное обеспечение, предназначенное для сквозного проектирования радио­электронных устройств, и состоит из следующих пакетов программ:

OrCAD Capture — программа создания принципиальных схем проектов всех типов: синтез ПЛИС (программирование логических интегральных схем) и моделирование цифровых устройств с помощью OrCAD Express, моде­лирование смешанных аналого-цифровых устройств и их параметричес­кая оптимизация с помощью OrCAD PSpice и PSpice Optimizer, разработ­ка печатных плат с помощью OrCAD Layout;

OrCAD Capture CIS (Component Information System) — программа создания принципиальных схем, имеющая доступ к базам данных ведущих фирм-производителей электрюнных компонентов через Интернет с помощью службы ICA (Internet Component Assistant); зарегистрированные пользо­ватели получают доступ к каталогу, содержащему более 200 тыс. компо­нентов, либо к локальным или корпоративным базам данных радиоэле­ментов предприятия;

PSpice — моделирование аналоговых устройств. Обеспечивает как стандарт­ные методы анализа: расчет режима по постоянному току, частотных характеристик и переходных процессов, так и многовариантный и стати­стический анализ по методу Монте-Карло, расчет чувствительности схе­мы к разбросу параметров компонентов и проверка работоспособности для наихудшей комбинации отклонений от номинала, графический ана­лиз формы сигнала, анализ производительности по результатам модели­рования, графическое редактирование входных сигналов, полуавтоматическое опи­сание полупроводниковых устройств на основе данных производителя. Библиотеки аналоговых моделей содержат более 12 тыс. устройств (дио­ды, биполярные и полевые транзисторы, мощные МОП-транзисторы, операционные усилители, стабилизаторы, регуляторы и компараторы напряжения, нелинейные магнитные устройства, тиристоры, оптроны, кварцевые резонаторы и др.). Новый интерфейс программы PSpice имеет окно для просмотра графиков результатов моделирования, параметры всех директив моделирования, значения глобальных параметров, список подключенных библиотек математических моделей и другие параметры заносятся в отдельный текстовый файл *.sim;

PSpice A/D — моделирование аналоговых и смешанных аналого-цифровых устройств. Алгоритмы аналогового и цифрового моделирования взаимо­увязаны в рамках одной программы, которая автоматически распознает и обрабатывает аналого-цифровые и цифро-аналоговые интерфейсы. Биб­лиотеки цифровых ИС включают в себя ИС серии 7400, ТТЛ ИС с диодами Шоттки, ИС на КМОП-структурах, программируемые логичес­кие матрицы и др.;

PSpice A/D Basics — упрощенные версии пакета PSpice A/D;

PSpice Optimizer — оптимизация параметров для достижения заданных харак­теристик смешанных устройств. Обеспечивает оптимизацию на основе градиентных методов при наличии линейных и нелинейных ограниче­ний. Оптимизация проводится автоматически или интерактивно до пол­ного удовлетворения условий, заданных пользователем. Поддерживается оптимизация с нелинейными целевыми функциями. Запускается из обо­лочки программы Capture.

OrCAD Layout Engineer's Edition — графический редактор печатных плат OrCAD Layout без автотрассировщика, и предназначен для совместной работы над проектом печатной платы группы разработчиков. Программа для просмотра печатных плат, созданных с помощью Layout или Layout Plus, средство общей расстановки компонентов на плате и прокладки наиболее критических цепей, выполняемых инженером-схемотехником перед выдачей задания на проектирование печатной платы конструктору (аналог программы ACCEL Relay). В OrCAD Layout, OrCAD Layout Plus и OrCAD Layout Engineer's Edition обеспечена двусторонняя передача данных между ними и программами разработки печатных плат MicroSim PCBoards и SPECCTRA (в прежних версиях можно обмениваться данны­ми лишь с P-CAD, Tango, PADS, Protel и AutoCAD);

OrCAD GerbTool — программа создания и доработки управляющих файлов для фотоплоттеров (разработка фирмы WISE Software Solutions специаль­но для OrCAD, аналог программы САМ-350);

Visual CADD — графический редактор фирмы Numera Software (упрощенный аналог AutoCAD).

Сложность проекта

  • максимальный размер печатной платы — 144x144 дюйма;

  • общее число слоев — 30;

  • число одновременно разводимых слоев — 16;

  • 7500 компонентов на плате;

  • 10000 цепей на плате;

  • 32000 связей на плате;

  • 7500 компонентов разного типа на плате;

  • 3200 выводов в компоненте;

  • 1000 различных контактных площадок;.

  • 250 различных переходных отверстий;

  • разрешающая способность на плате — 1/16 дюйма или 1 мкм;

  • дискретность угла поворота — 1 угловая минута.

Системные требования к аппаратуре и программному обеспечению: OrCAD 9.x работает в среде Windows 95/98 и Windows NT 4.0 (с Service Pack 3 или Service Pack 4), необходим Pentium с ОЗУ 32 Мбайт. Для отдельных модулей на жестком диске требуется объем памяти:

OrCAD Capture – 75 Мбайт;

OrCAD PSpice – 50 Мбайт;

OrCAD CIS – 20 Мбайт;

OrCAD Layout – 90 Мбайт.


2.2. Создание условных графических обозначений


Библиотеки — это файлы, которые содержат радиоэлементы для создания электрических схем. Библиотеки могут также содержать раз­личные символы, такие как «земля» и «питание», а также набор штампов. Вы можете создавать собственные новые библиотеки, пользо­ваться уже созданными и корректировать уже созданные библиотеки. Не надо создавать библиотеку специально для проекта. Каждый про­ект имеет специальную память, DESIGN CACHE, в которой хранятся все элементы, используемые в проекте.

Чтобы создать новую библиотеку, нужно войти в меню File — NEW — LIBRARY. Появится окно с названием LIBRARY1, содержа­щее все необходимые папки для ведения библиотеки. Рекомендуется сразу же присвоить имя библиотеке — набрать File — Save As.

Если вы хотите работать с уже созданной библиотекой — наберите File — OPEN, задайте имя библиотеке. В окне Администратора проек­тов высветится перечень всех элементов и символов, хранящихся е библиотеке. Чтобы отредактировать элемент, нужно два раза щелкнуть по нему мышью, и элемент появится в окне редактора элементов.

Если вы хотите создать новую библиотеку на базе старой с изме­ненными элементами, то после загрузки библиотеки присвойте ей сразу новое уникальное имя, чтобы изменения не попали в исходную библиотеку.

Вы можете также переместить или скопировать ряд элементов из одной библиотеки в другую. Для этого откройте обе библиотеки и расположите их окна рядом. Мышью перетащите нужный элемент в окно другой библиотеки на значок с ее названием, при этом курсор из перечеркнутой окружности примет вид вертикальной черты с прямоу­гольником внизу. Должно появиться сообщение:

ARE YOU SURE YOU WANT TO MOVE THE PART

Чтобы скопировать элемент в другую библиотеку, нужно сделать то же самое при нажатой клавише CTRL.

Когда вы первый раз вызываете элемент из библиотеки и размеща­ете его в схеме, копия этого элемента помещается в кэш проекта. Кэш содержит по одной копии каждого элемента, используемого в проекте. Обычно все вхождения элемента ссылаются на эту копию. Запись или замещение копии элемента в кэше происходит при каждом новом вызове элемента из библиотеки.

Существует несколько способов редактирования элемента уже вклю­ченного в схему.

Можно отредактировать элемент непосредственно в схеме. Для этого нужно щелкнуть один раз по элементу, чтобы он заключился в рамку, нажать правую клавишу и в появившемся меню выбрать пункт Edit PART. Вы попадете в окно редактирования элемента. Закончив редактирование, закройте окно, при этом появится окно, предлагаю­щее выбрать одно из следующих действий:

Update Current — заменить только текущий элемент;

Update All — заменить все элементы этого типа;

Discard — отменить изменения.

Если вы замените только текущий элемент, то в кэше появится новая копия этого элемента, потерявшая связь с библиотекой, наряду со старой копией. Теперь, если вы хотите разместить в схеме исправ­ленный элемент, то нельзя пользоваться командой PART, а нужно пользоваться командой COPY и PASTE из меню Edit.

Элементы в кэше сохраняют связь с библиотекой, так что при изменении элемента в библиотеке мы можем всегда синхронизировать элементы в кэше с библиотекой. Для этого откроем проект в Design cache, выделим элемент, который мы хотим отредактировать, и в меню Design выберем пункт UPDATE CACHE. Все элементы этого типа заменятся на отредактированные, за исключением тех элементов, которые редактировались непосредственно в схеме.

Чтобы восстановить связь с библиотекой, нужно воспользоваться командой Replace Cache. Для этого откроем проект, в кэше выберем нужный элемент и в меню Design выберем команду Replace Cache. Появится окно, содержащее имя элемента, который мы хотим заменить, и имя его библиотеки, в данном случае, так как он хранится только в кэше, появится имя проекта. Заменим имя отре­дактированного элемента на его библиотечное имя, а имя библиотеки, на имя той библиотеки, из которой мы хотим выбрать элемент.

Вы можете создать новый элемент, отредактировать старый в библиотеке или непосредственно в схеме.

Чтобы создать новый элемент, нужно открыть новую или суще­ствующую библиотеку и из меню Design выбрать пункт New Part.

Чтобы откорректировать существующий элемент, нужно открыть библиотеку и два раза щелкнуть мышью по его имени.

Чтобы откорректировать элемент в схеме, нужно выбрать элемент на схеме и в меню Edit выбрать команду PART.

Элементы подразделяются на примитивные и непримитивные Примитивные элементы не содержат иерархии. Непримитивные эле­менты описываются как иерархические. Это свойство определяется в окне PROPERTIES, переключателями Primitiv YES, NO.

Элементы могут быть разделены на несколько логических элемен­тов, находящихся в одном корпусе,— PACKAGE. Каждый логический элемент имеет графическое тело, контакты и свойства, которые его описывают. Если логические элементы идентичны, исключая контак­ты, то это гомогенный элемент. Например, 6 инверторов в одном корпусе. Если логические элементы имеют различную графику, коли­чество контактов или свойства — это гетерогенные элементы. Напри­мер, реле.

Каждый элемент может содержать графику, текст, контакты и IEEE символы. Графика всегда находится внутри тела элемента, в то время как IEEE символы и текст могут находиться внутри и снаружи тела элемента. Контакты касаются границы тела элемента — бордюра, который определяет размер элемента и его форму.

Создание нового элемента

Создание элемента производится в три этапа:

определение элемента;

добавление графики;

размещение контактов.

Определение элемента

Перед тем как вы начнете рисовать новый элемент, вы должны задать специальную информацию об элементе. Откройте библиотеку и из меню DESIGN выберите пункт NEW PART. Появится окно зада­ния свойств нового элемента — New Part Properties. Сначала задается ими элемента. Если элемент содержит в себе несколько логических элементов, вы должны задать их количество и тип элемента — гомо­генный и гетерогенный. Задав эту информацию, вы можете присту­пить к прорисовке графики.

В строке Name вы задаете имя элемента, в строке Part Reference Prefix задается буква позиционного обозначения элемента, например, С для конденсаторов. Строку РСВ Footprint заполнять необязательно — тип корпуса. Переключатель Create Convert View включается, если элемент имеет эквивалент DeMorgan. Parts per Pkg — количество логических элементов в корпусе. Part Numbering — определяет как обозначается логический элемент в корпусе — цифрой или буквой, например, DD12.1 или DD12.A.

После того как вы задали тип элемента и нажали кнопку ОК, окно закроется и появится окно редактора, в котором пунктирной линией — БОРДЮРОМ — определена граница тела элемента. Контакты все­гда располагаются с внешней стороны тела, касаясь бордюра. Назва­ние элемента VALUE (значение строки Name) располагается под телом, позиционное обозначение — над элементом. В заголовке окна редактора отображается название библиотеки и имя элемента.

Если вы создаете элемент, содержащий несколько логических эле­ментов, то в окне редактора будет находиться первый элемент. Если это гомогенный элемент, то все редактирование, которое производится с первым элементом, будет автоматически распространяться на все элементы пакета (исключая изменения номеров контактов). Если вы создаете гетерогенный элемент, редактирование распространяется толь­ко на один элемент. Чтобы отредактировать другой элемент, нужно выбрать Next Part или Previous Part из меню VIEW. Чтобы просмот­реть все элементы в пакете, выберите VIEW — PACKAGE и, щелкнув два раза по любому из элементов, вы можете отредактировать его. Чтобы просмотреть всю информацию о пакете, выберите последова­тельно VIEW — PACKAGE, Edit — Properties. Вы увидите на экране таблицу, показывающую всю информацию о контактах.

Чтобы изменить размер тела элемента, выделите бордюр и растя­ните его до нужных размеров. Как только вы определили размер тела, вы можете нарисовать сам элемент. Вся графика должна находиться внутри бордюра. Если вы нарисуете что-нибудь вне его, бордюр авто­матически изменит размер и включит графику. Чтобы добавить графи­ку, вы должны пользоваться командами меню Place — Line, Rectangle, Ellipse, Arc, Polyline. Добавить текст командой TEXT. В меню Place также находится команда включения IEEE символов. Текст и IEEE символы могут находиться вне тела элемента.

Есть несколько способов размещения контактов на элементе. Ко­манда PIN в меню PLACE или кнопками панели инструментов Pintools, которая устанавливается через меню VIEW. Контакты должны касаться бордюра элемента, если бордюр и край тела совпадают, контакты будут располагаться непосредственно на крае тела элемента, если нет, то они будут продолжением линий, внутри тела. Для циф­ровых, цифро-аналоговых и аналоговых микросхем бордюр должен совпадать с границей тела элемента.

Выберите команду PLACE — PIN. Появится диалоговое окно, и вы должны задать информацию о каждом контакте. Когда вы опреде­лите все характеристики контакта, нажмите ОК. Указателем мыши поставьте контакты на нужное место и нажмите левую клавишу, чтобы зафиксировать контакт. Вы можете поставить сразу несколько контактов, каждый раз нажимая левую клавишу и размещая новый контакт. При этом имя и номер контакта назначаются автоматически с увеличением на единицу. Вы можете изменять свойства этих контак­тов, нажав правую клавишу и выбрав пункт Edit Properties. Чтобы закончить размещение контактов, выберите пункт End mode из меню правой клавиши или нажмите клавишу ESC.

Все характеристики контактов задаются через диалоговое окно Place Pin Dialog Box.

  1   2

Похожие:

Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconПрограмма дисциплины Информационные технологии проектирования электронных средств» для специальностей 210201 «Проектирование и технология радиоэлектронных средств»
Для специальностей 210201 «Проектирование и технология радиоэлектронных средств» 210202 «Проектирование и технология электронно-вычислительных...
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconРабочая программа по дисциплине "Физические основы микроэлектроники" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств»
Целью курса является подготовка в области физических основ микроэлектроники студентов специальности «Конструирование и технология...
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconПрограмма дисциплины «Технология радиоэлектронных средств»
Программа предназначена для преподавателей, ведущих данную дисциплину, учебных ассистентов и студентов направления подготовки специальности...
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconМетодические указания по дипломному проектированию для студентов специальности 200800 “Проектирование и технология
Методические указания предназначены для студентов Факультета информатики и телекоммуникаций, обучающихся по направлению "Проектирование...
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconМетодическое пособие по курсовой работе для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств», 230101 «Вычислительные машины, комплексы, системы и сети» Сарапул 2007 г
Методическое пособие предназначено для студентов, обучающихся по специальности 210201, 230101 при выполнении ими курсовой работы...
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconМетодические указания к лабораторным работам по дисциплине «Технология литейного производства»
К лабораторным работам по дисциплине «Технология литейного производства», курс «Формовочные материалы» для студентов специальности...
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconРабочая программа преподавания дисциплины «Информационные технологии проектирования рэс»
Выписка из Государственного стандарта высшего профессионального образования направления подготовки дипломированного специалиста 654300...
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconРабочая программа учебной дисциплины дизайн и эстетика для специальности 210201 проектирование и технология радиоэлектронных средств радиотехнического факультета
Министерство образования и науки российской федерации воронежский государственный технический университет
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconРабочая программа По дисциплине «Системный анализ в сервисе брэа» для специальности. Специализация
Рабочая программа составлена на основании гос впо 200800-95 по специальности 210201? – Проектирование и технология радиоэлектронных...
Методические указания к лабораторным работам №1, 2 по дисциплине \"Проектирование и технология изготовления приемопередающих устройств мобильных радиостанций\" для студентов специальности 210201 «Проектирование и технология радиоэлектронных средств» iconМетодические указания к курсовой работе по дисциплинам: «Техническое обеспечение и внешние устройства эвм»
Мс-51. Указания предназначены для студентов дневной формы обучения специальностей: 220500 – Проектирование и технология эвс, 200800...
Разместите кнопку на своём сайте:
Библиотека


База данных защищена авторским правом ©lib.znate.ru 2014
обратиться к администрации
Библиотека
Главная страница