Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005




Скачать 307.11 Kb.
НазваниеИнженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005
страница1/4
Дата07.02.2013
Размер307.11 Kb.
ТипДокументы
  1   2   3   4


658.512.2(07) 3715

C232

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

ФЕДЕРАЛЬНОЕ АГЕНТСТВО ПО ОБРАЗОВАНИЮ

Государственное образовательное учреждение

в
ысшего профессионального образования





СБОРНИК ЛАБОРАТОРНЫХ РАБОТ,

выполняемых с использованием программ

AutoCAD 2004, T-Flex CAD 3D 7.0


по курсу


Инженерная и компьютерная графика


Для студентов специальностей 2205, 2019





Таганрог 2005


УДК 658.512.2.011.5:744(076.5)+658.512.2.011.5:681.3.06(076.5)

+681.327.22.06(076.5)


Составители: Е.Б.Лукьяненко, Е.Т.Замков, Л.Е.Жейц


Сборник лабораторных работ, выполняемых с использованием программ AutoCAD 2004, T-Flex CAD 3D 7.0. Таганрог: Изд-во ТРТУ, 2005. 39 с.


В лабораторной работе рассматриваются приемы работы с англоязычной версией AutoCAD 2004. Приводятся сведения о настройке рабочих режимов. Подробно рассматривается процесс вычерчивания электрической схемы. Описан способ создания и использования блоков. Рассматриваются приемы создания трехмерных фигур. Русскоязычная программа T-Flex изучается в плане применения для создания объемных корпусов приборов с современным дизайном.


Ил. 35. Библиогр. : 5 назв.


Рецензент О.Н. Негоденко, д-р.техн.наук, профессор кафедры МЭТ БИС ТРТУ.


1. ИЗУЧЕНИЕ ПРОГРАММЫ AutoCAD 2004


Лабораторная работа №1


Настройка рабочих режимов


1.1. Начало работы в программе AutoCAD


После загрузки AutoCAD на мониторе появляется рабочий экран (рис.1).





Рис. 1


Выполнение операций рисования производится путем ввода команд. Команды вводятся из главного меню, экранного меню, командной строки путем набора команд на клавиатуре, активизацией кнопок в статусной строке или с помощью панелей инструментов.

После ввода команды AutoCAD выдает запросы в командной строке или вызывает диалоговое окно. Некоторые команды допускают работу через командную строку и через диалоговое окно. Для подавления вывода диалогового окна надо ввести знак «–» (минус) перед командой, набираемой в командной строке. Если набрать команду LAYER – то выводится диалоговое окно, а если –LAYER, то после нажатия ENTER в командной строке появляется соответствующий запрос на выбор следующего шага в выполнении вызванной команды. Набирается ответ, нажимается ENTER и т.д.

Очистить командную строку можно, нажав Esc.

Для повторения последней команды (когда команда выполнена и в командной строке имеется приглашение Command:) надо нажать ENTER или пробел.

Начинать работу с программой лучше всего с ввода следующих трех команд, набираемых в командной строке:

  • Limits – устанавливает границы чертежа, в которых видима координатная сетка. Сначала указывается левый нижний угол:




нажимается Enter, а затем набираются координаты правого верхнего угла и нажимается Enter:



(данные приведены для формата А4).

  • Grid – устанавливается шаг сетки. При разработке электрических схем рекомендуется устанавливать шаг равным 5 мм:




  • Snap – привязка курсора к узлам координатной сетки. Привязка выбирается обычно равной шагу сетки:



Видимость сетки можно включить/выключить щелчком мыши на кнопке Grid в статусной строке (или нажатием на клавишу F7 клавиатуры). Режим привязки курсора управляется щелчком мыши на кнопке Snap статусной строки (или клавишей F9 клавиатуры).

Кнопка Orth в статусной строке устанавливает/отменяет ортогональный режим проведения линий (или клавишей F8 клавиатуры). При включении соответствующего режима кнопка команды в статусной строке становится нажатой (утопленной). При повторном щелчке мышью команда изменяется на противоположную.

Если навести курсор на кнопку в статусной строке, вызвать контекстное меню нажатием правой кнопки мыши и выбрать команду Setting, то в открывшемся окне (рис. 2) можно просмотреть существующие установки режимов рисования и внести в них необходимые изменения.





Рис. 2


1.2. Настройка слоев чертежа


Щелчком мыши на значке панели инструментов, а также по командам DDLMODES или Layer, набранным в командной строке, вызывается окно настройки слоев (рис.3).




Рис. 3

Для создания новых слоев в этом же окне нажимается кнопка New. При последовательном нажатии кнопки автоматически создаются слои Layer1, Layer2 и т.д., имена которых можно изменить. Цвет слоя устанавливается (или изменяется уже существующий цвет) щелчком мыши на цвете слоя (Color) и в раскрывшемся окне выбирается необходимый цвет слоя. После чего окно закрывается нажатием на кнопку ОК.

Затем выбирается слой, в котором будут производиться графические работы. Для этого раскрывают значок, в котором указаны все созданные слои и выбирают слой щелчком мыши на нужном слое (рис. 4).





Рис. 4


Слой можно сделать невидимым щелчком мыши на соответствующем значке (лампочка). Для того, чтобы сделать слой недоступным для редактирования, устанавливают замочек в положение «закрыто».

Изменить цвет выделенного объекта или перенести выделенный объект в другой слой можно по команде DDCHPROP или по команде главного меню Format / Layer, или нажатием на кнопку . При выполнении указанных команд открывается окно (рис. 5).




Рис. 5


В поле Color этого окна изменяется цвет объекта, в поле Layer – принадлежность объекта слою, в поле Line – толщина линии, которая отображается на чертеже при нажатой кнопке LWT в статусной строке, и другие свойства выделенного объекта. Затем окно закрыть. Чтобы выполненные команды отобразились на экране иногда требуется перерисовать экран по команде Regen, набранной в командной строке.

Когда чертеж выводится в пространстве модели, толщина линий не изменяется при увеличении изображения, а в пространстве листа – пропорционально изменяется.


1.3. Система единиц


Установка формата и точности отображения как линейных, так и угловых размеров производится по команде DDUNITS или из главного меню Format / Units (рис.6).





Рис.6


Обычно устанавливается метрическая система линейных единиц (Decimal) и отображение углов как десятичных чисел (Decimal Degrees). Точность отображения размеров устанавливается в поле Precision.


1.4. Режимы рисования


Режимы рисования устанавливаются по команде DDRMODES или из главного меню Tools / Drafting settings. В раскрывшемся окне (см. рис. 2) можно установить шаг сетки и привязку к прямоугольной сетке, объектную привязку, полярную сетку.

Для настройки режимов применяют системные переменные, набранные в командной строке, например:

  • Fill – режим закраски (OFF – выключен, ON – включен);

  • Blipmode – показ маркеров (OFF – выключен, ON – включен);

  • Dragmode – отслеживание перемещения объекта (OFF – выключено, AUTO – включено);

  • Ucsicon – управление видимостью системы координат (OFF – выключено, ON – включено).

1.5. Установка цвета экрана и размера курсора


Для управления этими установками выбирается команда из главного меню Tools / Options. В открывшемся окне (рис.8) нажимают на кнопку Display и далее на кнопку Colors. Цвет экрана выбирается из базовых цветов (Basic Colors). Удобно использовать экран серого цвета как менее утомительный для глаз. Размер курсора по умолчанию устанавливается 5% к размеру экрана. Можно увеличить размер курсора до 100% в поле Grosshair size.





Рис. 8


1.6. Штриховка


Штриховка выполняется по команде Draw / Hatch или по одноименному значку команды . При этом активизируется окно (рис. 9).




Рис. 9


Для создания пользовательской штриховки выбирается тип User defined. Вводится угол наклона линий штриховки (поле Angle) и расстояние между линиями (поле Spacing). Нажимается кнопка Pick Points и указывается точка внутри замкнутого контура щелчком левой кнопки мыши. Если селектировать другие области не надо, то нажимается Enter и в появившемся окне нажимается ОК. Для заливки областей используется стандартная штриховка Solid.


Лабораторное задание. Выполнить в программе AutoCAD 2004 пп.1-3 задания:


1. Настройка слоев чертежа.

Открыть лист А4. Установить шаг сетки и привязки к узлам сетки 5 мм.

а) создать слои с именами layer1, «Круг», «Прямоугольник». Установить цвета в слое круг – синий, в слое прямоугольник – красный;

б) нарисовать в слое «Круг» – круг, в слое «Прямоугольник» – прямоугольник, в слое «0» – квадрат, в слое layer1 – несимметричную фигуру. Подписать рисунки «Круг», «Прямоугольник» и т.д.;

в) изменить цвет слоя «Круг» на зеленый;

г) перенести прямоугольник в слой «0»;

д) сделать слой «Круг» невидимым;

е) переместить прямоугольник на поле чертежа в другое место;

ж) повернуть квадрат на 45 градусов;

з) увеличить количество прямоугольников до 3;

и) зеркально отобразить несимметричную фигуру;

к) увеличить размеры прямоугольника в 2 раза;

л) увеличить изображение квадрата на весь экран, не изменяя размеров;

м) установить толщину линий квадрата, равную 1 мм;

н) заштриховать прямоугольник.


2. Изучение системы отображения линейных и угловых размеров.

Установить метрическую систему единиц и проставить размеры прямоугольника по команде Dimension / Linear.


3. Режимы рисования:

а) по команде Pline (полилиния) нарисовать линию шириной 5 мм. Для этого указать стартовую точку, набрать в командной строке букву W (слово Width – ширина), указать стартовую ширину. Затем в следующей строке указать конечную ширину полилинии. Указать курсором конечную точку линии;

б) выключить (включить) режим закраски. Регенерировать изображение по команде Regen.

в) выключить режим отслеживания при перемещении фигуры. Переместить фигуру. Включить режим отслеживания и переместить фигуру;

г) отключить видимость системы координат;

д) включить показ маркеров.

4. Установка цвета экрана и размера курсора:

а) установить цвет экрана сначала серый, а затем – белый;

б) увеличить размер курсора на весь экран.

Лабораторная работа №2


Создание блоков элементов электрической схемы


Для создания блока необходимо открыть лист. Включить режимы Grid и Snap, установить шаг сетки и привязки равными 5 мм. Нарисовать блок. Выводы блока должны совпадать с узлами сетки. Для этого надо отметить точки выводов элемента, например, уголками. Затем можно перейти к более мелкому шагу сетки и рисовать элемент электрической схемы. После того, как блок нарисован, производятся следующие действия:

1. Вводится команда Wblock. Нажимается Enter.

2. В открывшемся окне (рис. 10) в группе Source выбрать Object.

3. В группе Base Point щелкнуть мышью на кнопке Pick Point и на чертеже указать базовую точку (левая нижняя точка вывода элемента).

4. В группе Objects щелкнуть мышью на кнопке Select objects и селектировать (выделить) блок. Нажать Enter.

5. В группе Objects можно установить точку в поле Delete from drawing (удалить старый чертеж).

6. В строке Destination указать имя и путь к создаваемому блоку.

7. В строке Insert Units указать единицы измерения (миллиметры).




Рис. 10

При создании блоков используются различные приемы, описанные в разделах 2 и 3.


2.1. Вставка блоков на поле чертежа


Вставка элементов производится щелчком мыши на значке (Insert Block) или по команде DDINSERT. Диалоговое окно этой команды приведено на рис. 11.





Рис. 11


В строке Name указать имя вставляемого блока. Пометить галочкой поля: Insert Point, Scale, Rotation. Нажать ОК. Нажать ОК, ОК, ОК (или ответить на запросы программы). Если элементы занимают небольшую часть чертежа, то область схемы можно увеличить на весь экран щелчком мыши на значке (Zoom Extents).


Лабораторное задание. Создать блоки элементов, входящих в электрическую схему, выданную преподавателем из методички №2923. Размеры и конфигурация элементов должны соответствовать ГОСТам на элементы. Выводы элементов должны заканчиваться в узлах пятимиллиметровой координатной сетки.


Лабораторная работа №3


Создание чертежа схемы электрической

принципиальной


Сначала открывается формат А4 и сохраняется по команде Save As в каталоге бригады. Вставляются условные графические обозначения элементов в одном экземпляре, а затем путем копирования увеличивается количество элементов до нужного значения.


3.1. Копирование элементов


Копирование производится по команде Copy или щелчком мыши на значке (Copy Object). Режимы Grid и Snap – включены, Ortho – выключен. После вызова команды появляется запрос на выделение объекта «Select Objects:». После его выделения (щелчком мыши на объекте или заключением его в прямоугольную рамку) появляется повторный запрос на выделение другого объекта. И если копировать больше ничего не надо, нажимается Enter. Появляется запрос на выбор базовой точки /Multiple:. Если надо создать несколько копий элементов, то выбирается ключ /Multiple (набирается буква m и нажимается Enter). Затем щелчком мыши выбирается точка перемещения (Base point:) и точка установки копии элемента (Second point of displacement:). Оканчивается вставка элемента нажатием правой кнопки мыши.


3.2. Перемещение элементов схемы


Для оформления схемы элементы надо расположить на поле чертежа так, чтобы схема легко читалась. Перемещение осуществляется по команде Move или щелчком мыши на значке этой команды . При перемещении элементов режимы Grid и Snap должны быть включены, режим Ortho – выключен. Запросы при перемещении аналогичны запросам, появляющимся при копировании элементов.


3.3. Поворот элемента


Поворот резисторов, конденсаторов, транзисторов и других элементов схемы осуществляется командой Rotate или с помощью значка этой команды . После выбора команды появляется запрос на выделение элемента, а далее запрашивается центр вращения (Base Point:) и угол поворота (Rotation Angle). Набирается значение угла и нажимается Enter.


3.4. Зеркальное отображение


Некоторые элементы иногда требуется расположить так, что разместить их можно только путем зеркального отображения. Для этого набирается команда Mirror или используется значок этой команды . Объект выделяется, после чего запрашивается первая точка оси отображения (First point of mirror line:). После щелчка мышкой на первой точке появляется запрос о второй точке оси (Second point:). Указывается вторая точка оси, затем появляется запрос на удаление исходного объекта (Delete old objects?). Если объект удалять не надо, то нажимается Enter. Если исходный объект надо удалить, то в строке набирается буква Y и нажимается Enter. Зеркальное отображение n-p-n-транзистора приведено на рис.12.





Рис. 12

3.5. Соединение элементов схемы


Соединение элементов может осуществляться по команде Line или использованием значка этой команды . При этом режимы Grid, Snap, Ortho должны быть активными.

Отрезки определяются двумя точками в пространстве по запросам: «line First point» (начало отрезка) и «To point» (конец отрезка). Цикл заканчивается нажатием Enter или щелчком правой кнопки мыши. Координаты точек проще всего вводить курсором, нажимая левую кнопку мыши.


3.6. Установка точек соединения


Установка точек соединения проводников осуществляется по команде копирования Copy с ключом /m. Режимы Snap, Grid – включены, режим Ortho – выключен. Эти режимы могут изменяться при выполнении других команд (прозрачный режим).


3.7. Ввод позиционных обозначений элементов


Перед вводом позиционных обозначений включается режим Grid и выключаются Snap и Ortho. Однострочный текст вводится командой из главного меню: Draw/Text/Single Line Text. На запрос «dtext Justify/Style/:» указывается начальная точка ввода текста щелчком левой кнопки мыши. Затем на запрос «Height» указывается высота прописных букв (рекомендуется 3.5). На следующий запрос «Rotation Angle» вводится угол поворота текста (против часовой стрелки).

После этого появляется запрос на ввод текста и в строку вводится позиционное обозначение элемента. После ввода текста можно указать маркером другую точку и разместить новый текст. Обозначив все элементы, на запрос нажимается Enter (без ввода текста). Затем введенные обозначения можно переместить на более подходящие места.

Введенный текст можно отредактировать. Для этого выбирается команда из главного меню Modify/Object/Text/Edit, выделяется текст, в открывшемся окне текст редактируется и нажимается ОК. После чего нажимается Enter.

3.8. Удаление и восстановление объектов


Ненужные объекты удаляются с поля чертежа путем их выделения и набором команды Erase или выбором ее значка . Действие команды может быть отменено по команде Undo (ее значок ) . Нажимая несколько раз на этот значок, можно последовательно отменять предыдущие команды, начиная с последней.


3.9. Управление изображением чертежа


В процессе работы зачастую возникает необходимость изменения масштаба отображения чертежа в графической зоне экрана. Для этого служит команда View/Zoom или ее значки :

(Zoom Window) – увеличивает изображение, заключенное в прямоугольную рамку на весь экран;

(Zoom Realtime) – изменение масштаба изображения путем перемещения курсора при нажатой левой кнопке мыши. Снизу-вверх – увеличение масштаба, сверху-вниз – уменьшение ;

(Zoom Extens) – увеличение чертежа на весь экран;

(Zoom In), (Zoom Out) – дискретное увеличение или уменьшение масшатаба чертежа.

Перемещение чертежа по экрану осуществляется линейками прокрутки или, более эффективно, с помощью значка (Pan Realtime). Щелкнув левой кнопкой мыши на этом значке, переводим курсор на поле чертежа и при нажатой левой кнопке мыши перемещаем чертеж по экрану. Для отмены команды нажимаем Enter или Esc, либо вызываем контекстное меню щелчком правой кнопки мыши и выбираем Exit.

В заключение чертеж увеличивается на весь экран и сохраняется по команде File/Save as в выбранном каталоге с расширением *.dwg.


Лабораторное задание. Выполнить на формате А4 схему электрическую принципиальную. Заполнить основную надпись.


Лабораторная работа №4


Нанесение размеров на чертеж

  1   2   3   4

Похожие:

Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconАннотация примерной программы дисциплины «Инженерная и компьютерная графика» Рекомендуется для направления подготовки
Курс «Инженерная и компьютерная графика» является базовым курсом, изучаемым студентами инженерного профиля. По этому курсу читаются...
Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 icon«Инженерная и компьютерная графика»
Для специальностей (направлений) 210100 «Управление и информатика в технических системах»
Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconМетодические указания к выполнению заданий по курсу «Инженерная графика»
Геометрическое черчение : методические указания к выполнению заданий по курсу «Инженерная графика» для студентов всех специальностей...
Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconРабочая программа учебной дисциплины опд. Ф. 01. 01 «Начертательная геометрия. Инженерная и компьютерная графика»
«Начертательная геометрия. Инженерная графика», утвержденной департаментом образовательных программ и стандартов профессионального...
Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconАверин В. Н. Компьютерная инженерная графика: учеб пособие / В. Н. Аверин
Аверин В. Н. Компьютерная инженерная графика: учеб пособие / В. Н. Аверин. М.: Академия, 2011. 224с
Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconИнженерная и компьютерная графика

Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconПрограмма элективного курса «Компьютерная графика»
Целью элективного курса «Компьютерная графика» является подготовка обучающихся и студентов по применению персональных компьютеров...
Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconСогласовано зам директора по увр
Кузнецов, В. В. Компьютерная графика. Coreldraw: Задания для проведения контрольной работы №1 «Компьютерная графика и цвет»
Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconКонспектлекци й
Учебное пособие предназначено для обеспечения курса «компьютерная графика» для студентов специальностей «Вычислительные машины, комплексы,...
Инженерная и компьютерная графика Для студентов специальностей 2205, 2019 Таганрог 2005 iconРабочая программа дисциплины «Инженерная графика» для специальности
«Инженерная графика» предназначена для реализации государственных требований к минимуму содержания и уровню подготовки выпускника...
Разместите кнопку на своём сайте:
Библиотека


База данных защищена авторским правом ©lib.znate.ru 2014
обратиться к администрации
Библиотека
Главная страница